cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Could not forsake node after disable oneagent traffic collecting

IvanVovk
Participant

Hello there. Give some advice please.

I've a 6-node cluster and its suffering Cassandra degradation.

One of features to stabileze normal working is to disable collecting data from oneagent.

after disabling oneagent traffic i'm getting an error:

Could not forsake node nodename. Check logs for details..

There is no helpful information in logs, only mesages like that

2020-06-30 06:27:16 UTC Launching command: /app/dynatrace/bin/installer/bin/configurator --cluster-nodes set-json {"clusterNodes":[{"id":1,"ipAddress":"10.x.x.x","webUI":true,"agent":true,"datacenter":""},{"id":2,"ipAddress":"10.x.x.x","webUI":true,"agent":true,"datacenter":""},{"id":3,"ipAddress":"10.x.x.x","webUI":true,"agent":true,"datacenter":""},
{"id":4,"ipAddress":"10.x.x.x","webUI":true,"agent":true,"datacenter":""},{"id":5,"ipAddress":"10.x.x.x","webUI":true,"agent":true,"datacenter":""},{"id":6,"ipAddress":"10.x.x.x","webUI":true,"agent":true,"datacenter":""}]}
2020-06-30 06:27:17 UTC Launching command: /app/dynatrace/bin/installer/bin/configurator --cluster-nodes get-all-json
2020-06-30 06:27:17 UTC Failed, with exit code 10


What does it mean? In CMC I see that these nodes are in OneAgent traffic disabled mode, but it's really is?

How to check that it's ok with nodes and they are working properly?

5 REPLIES 5

Radoslaw_Szulgo
Dynatrace Guru
Dynatrace Guru

OneAgent traffic disabled = Node in "Forsaken" state

From the logs you pasted - seems you've launched an operation to turn on OneAgent traffic on all nodes -> "agent":true,


Why it has failed? Hard to tell. Usually exit code '10' means there's no installer file in the node. Was it removed? Can you provide installer logs?

Or you can also open a support case 😉

Senior Product Manager,
Dynatrace Managed expert

I cann't find in support archive installer logs. Can you suggest where it's located? I tried to switch back to enable OneAgent traffic and it seems look good - without any error. After went back to Disable traffic and got the same error

server log for the start - from all nodes

Senior Product Manager,
Dynatrace Managed expert

Julius_Loman
DynaMight Guru
DynaMight Guru

Recently, I had an issue that turning off OneAgent traffic in CMC did not result in OneAgent traffic turned off. Had to enable and disable it again.

TEMPEST a.s., Slovakia, Dynatrace Master Partner

Its not working(