cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Deep monitoring of nginx

vinod_devi
Newcomer
Hi,
I get the below error. I am interested in all nginx monitoring that dynatrace can do. I am running the latest oneagent version on ubuntu 18.04
OneAgent version - 1.213.155.20210401-214003
nginx version - 1.19.8
 
Activation of deep monitoring was unsuccessful
Your Nginx build is not supported. The binaries are not listed in the Dynatrace repository and the OneAgent could not find debug symbols. Details on supported Nginx binaries can be found here: Dynatrace supported environments and versions
 
Why is it not working? Is there something I can do to get the deep monitoring to work?
1 REPLY 1

Julius_Loman
Leader

Hi,
as the message says - your build is not supported. NGINX is a native binary and compiled statically. OneAgent hooks on known symbols in NGINX.  Not sure what is your build you have several options:

  • use an nginx build with debug symbols
  • use a known nginx build (from known repository)
  • ask Dynatrace to support your build