cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Does Dynatrace support for Apache Synapse?

abilashinith
Participant

Does Dynatrace support for Apache Synapse?

18 REPLIES 18

MaciejNeumann
Community Team
Community Team

Hello @Abilashini T.,

On this documentation page, you can see all technologies and versions supported by Dynatrace:
Supported technologies and versions

As you can see, Apache Synapse isn't on this list, so as far as I know, it isn't supported at the moment.

If you have any questions about the Forum, you can contact me at maciej.neumann@dynatrace.com

Hi @MaciejNeumann ,

 

Any update for supporting  Apache Synapse?

It is a main technology for wso2 (that supported by Dynatrace) we need to monitor

Thanks,

Arnit

@arnit_kashi we have a custom solution based on OneAgent SDK to get full tracing across apache synapse (wso2).

Also there is another solution by @thomas_brandl  available here which uses opentracing to get end-to end traces:
https://github.com/tbrandl-dynatrace/wso2-apimanager-dynatrace/ 

The metrics are available as well out-of-box.

Certified Dynatrace Master | TEMPEST a.s., Slovakia, Dynatrace Master Partner

Thanks @Julius_Loman 

WSO2 version 2.2 was installed in our company.

the deployment.toml file is not fit, how can we get this to work on version 2.2?

@arnit_kashi  what version of synapse-nhttp-transport_2.1.7 does your installation have?

This file should be located in:
./repository/components/plugins/

Certified Dynatrace Master | TEMPEST a.s., Slovakia, Dynatrace Master Partner

synapse-nhttp-transport_2.1.7.wso2v48

@arnit_kashi Try to replace the library with the one attached. Don't forget to unzip it of course. Afterwards you need to restart the WSO2 instance.

This library adds instrumentation for the Apache Synapse classes to properly trace requests. Please keep in mind this is unsupported from Dynatrace ad WSO2, so I'd advise trying it in a non-production environment first.

Certified Dynatrace Master | TEMPEST a.s., Slovakia, Dynatrace Master Partner

Thanks @Julius_Loman , We'll test it in non-production, but we'll need wso2's permission to make the modification in production. Is it possible for you to send me the source with the changes?

Please test it in non-prod and if it solves your case, then contact me at julius_loman (at) tempest.sk 

Certified Dynatrace Master | TEMPEST a.s., Slovakia, Dynatrace Master Partner

Hi, 

We get an error 

Please see atached 

 

@arnit_kashi I think there was I mistake while replacing the jar.

Let's try it again. I've attached a new file.
Please:

  1. Rename the attached zip file to synapse-nhttp-transport_2.1.7.wso2v48.jar
  2. Replace the original file in ./repository/components/plugins/ with this new synapse-nhttp-transport_2.1.7.wso2v48.jar (keep the original for backup)
  3. Restart the WSO2 instance
Certified Dynatrace Master | TEMPEST a.s., Slovakia, Dynatrace Master Partner

 

We get an error 

 

Please see the atached file

 

 

@arnit_kashi  Ok, I see. Sorry we had a newer version of WSO2.

Please try it with the attached file once again :

  1. Rename the attached zip file to synapse-nhttp-transport_2.1.7.wso2v48.jar
  2. Replace the original file in ./repository/components/plugins/ with this new synapse-nhttp-transport_2.1.7.wso2v48.jar (keep the original for backup)
  3. Restart the WSO2 instance
Certified Dynatrace Master | TEMPEST a.s., Slovakia, Dynatrace Master Partner

@Julius_Loman We continue to receive the same error.

@arnit_kashi unfortunately we could not replicate your issue on the same WSO2 version you have. It's probably related to your WSO2 setup or installation. The exception is thrown on the line which is not related to the modification.

Do you stop receiving the exception when you restore the original jar file?

Certified Dynatrace Master | TEMPEST a.s., Slovakia, Dynatrace Master Partner

yes, we stop receiving the exception when we restore the original jar file.

It could be caused by a different aspectj library (wso2.2 does not include one in the opensource version). Our extension uses AspectJ and as the WSO2.2 did not include one, we added it in the latest library.

I'm afraid we cannot help you without access to your WSO2 installation.

Certified Dynatrace Master | TEMPEST a.s., Slovakia, Dynatrace Master Partner

@Julien unfortunately we can not do this because of security policy..

any suggestion will be appreciated and thanks for all until now 😊