cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Dynatrace CICS ZDTPLTxx upgrade

Liyongjian
Newcomer

Hi team

 

Hi team


Im using Dynatrace version 7.2 in Z/OS for CICS.

For the CICS old version 5.1 , we use ZDTPLT68 in PLT list table.

And now the CICS TS version upgrade to the 5.4.


a.Do it need change program in PLT table from ZDTPLT68 to ZDTPLT71 ?

b. ZDTPLT with suffix (67/68/69/70/71/72/73)

Is their relationship a one-to-one correspondence?


EX. CICS TS 5.1---ZDTPLT68

CICS TS 5.2---ZDTPLT69

CICS TS 5.3---ZDTPLT70

CICS TS 5.3---ZDTPLT71

 

 

2 REPLIES 2

sebastien_arjo
Visitor

Hello Liyongjian

 

Yes you 'll need to change the level of the PLT program ZDTPLT according to the level of CICSTS.

for CICSTS 5.4, the corresponding PLT program is ZDTPLT72.

But there is an easier way to process. 

Mention in the PLT Table the alias program called ZDTPLT only, then in your library or DFHRPL, the associated program will be choosen according to your CICSTS level .

Example : 

DELIM DFHPLT TYPE=ENTRY,PROGRAM=DFHDELIM
-----
DFHPLT TYPE=ENTRY,PROGRAM=ZDTPLT DYNATRACE
DFHPLT TYPE=FINAL
END

 

in your DFHRPL :

//DD DISP=SHR,DSN=bib dynatrace 7.2 (SZDTLOAD)

 

Regards

Sebastien

Correction :

CICSTS54 is corresponding to ZDTPLT71

 

Regards