cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Dynatrace Cocoapods version 8.227 not available

babu1390
Visitor

Hi Team , In the Dynatrace documentation i could see Cocoapods 

pod 'Dynatrace' , '~> 8.227'

 

But when i try to do its giving me error which is not avail yet and without version if i try to install its doing 8.219.1 which looks older. But the latest version 8.227 is avail for Swift package manager and why its not available in cocoapods yet

3 REPLIES 3

harp
Dynatrace Pro
Dynatrace Pro

Everything up to 8.229 should be available for Cocoapods, Carthage and Swift Package manager.
Regarding Cocoapods, did you just to a `pod install`? You might need to perform either `pod update`, `pod update Dynatrace` to update Dynatrace or other pods or `pod repo update` before `pod install` to check for latest version for Dynatrace or other pod. 

babu1390
Visitor

@harp : Could you see this screenshot , it still install 8.219.1 version

The screenshot does not reveal the version settings configuration for Dynatrace in the `Podfile` as this impacts what `pod update` does. `pod install` only installs the version stored in `Podfile.lock`.

But more important it seem that you have a custom source specs repo (sbx-ios-pods-iospodspecs) - if that is the case its very likely that your custom specs repo is out of sync with cocopods cdn/master repo! Dynatrace can only take care about the state of our product in the official Cocopods repos, not any custom repos (https://github.com/CocoaPods/Specs or https://cdn.cocoapods.org).