cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Dynatrace Managed with RHEL 8.2

kalle_lahtinen
Advisor

Hi,

We have new Managed environment being installed currently. The request I made for the server order stated that RHEL up to 8.1 is supported (like it currently says in the documentation), but the OS we got was RHEL 8.2 🙂

Would you recommend downgrading & reinstalling the OS to a supported version, or is the support for 8.2 basically around the corner? If it is, I'd prefer to keep this setup due to schedule constraints. Of course if the installer detects 8.2 and doesn't proceed because it's not supported, then I don't have a choice anyway... Not able to test that quite yet.

7 REPLIES 7

Radoslaw_Szulgo
Dynatrace Leader
Dynatrace Leader

Support for RHEL 8.2 will come with Dynatrace Managed Release 200 (October). To workaround the issue with installation on 8.2 you can just downgrade nftables to 0.9.0

Thanks Radoslaw! Appreciate it 🙂

kalle_lahtinen
Advisor

@Radoslaw S. we've downgraded nftables to 0.9.0 but installation failed with "Installation of Nodekeeper failed with error: Failed to start Nodekeeper, error: Redirecting to /bin/systemctl start dynatrace-nodekeeper.service"

...Looks like I need to create a ticket next.

Well but that then means installation Was completed, and something else Is wrong. We’d need to get installation logs and possibly system journal.

You are correct, the installation was basically finished even though I never got the "Installation completed successfully" response in the end. We managed to get this working by disabling SElinux. After that, Nodekeeper started ok. Once RHEL 8.2 is officially supported, do you think we can again enable SElinux and expect Nodekeeper to work normally..?

Hard to tell without knowing details. Have you opened a support ticket?


anyway, we haven’t fixed anything directly related to such issue. With version 1.200 installation works properly with newer nftables.

Hi,

Yes I did open the ticket, but it's closed already since the solution we figured ourselves was to simply disable SElinux 🙂 No worries, we'll cross that bridge when we get there. For now it's enough to have got the cluster installed.