cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error running monaco in container

naveen
Participant

Hi I am running monaco in container using monaco-runner image by dynatrace in Azure DevOps pipeline but I am getting below error.

 

ERROR Required flag "environments" not set
 
Steps:
1. docker pull dynatraceace/monaco-runner
2. docker run dynatraceace/monaco-runner monaco -e='environments.yaml' -p='Project1' --dry-run
 
Output:

You are currently using the old CLI structure which will be used by
default until monaco version 2.0.0

Check out the beta of the new CLI by adding the environment variable
"NEW_CLI".

We can't wait for your feedback.

NAME:
monaco - Automates the deployment of Dynatrace Monitoring Configuration to one or multiple Dynatrace environments.

USAGE:
monaco [global options] command [command options] [working directory]

VERSION:
1.5.0

DESCRIPTION:
Tool used to deploy dynatrace configurations via the cli

Examples:
Deploy a specific project inside a root config folder:
monaco -p='project-folder' -e='environments.yaml' projects-root-folder

Deploy a specific project to a specific tenant:
monaco --environments environments.yaml --specific-environment dev --project myProject

COMMANDS:
help, h Shows a list of commands or help for one command

GLOBAL OPTIONS:
--verbose, -v (default: false)
--environments value, -e value Yaml file containing environments to deploy to
--specific-environment value, --se value Specific environment (from list) to deploy to (default: none)
--project value, -p value Project configuration to deploy (also deploys any dependent configurations) (default: none)
--dry-run, -d Switches to just validation instead of actual deployment (default: false)
--continue-on-error, -c Proceed deployment even if config upload fails (default: false)
--help, -h show help (default: false)
--version print the version (default: false)
ERROR Required flag "environments" not set

2 REPLIES 2

david_lopes
Dynatrace Helper
Dynatrace Helper

Remove the "=" like the options suggest.

 

docker run dynatraceace/monaco-runner monaco -e environments.yaml -p Project1 --dry-run

Hi David thanks for the solution, actually problem was with docker container itself. It's working now with "=" also