cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Helm - Dynatrace Operator installations compatibility with OCP 3.11

alberto-jesus_1
Contributor

Hi,

there is a new update of the best approach about how to install Dynatrace in Openshift like Operator. It talks about using Helm package manager. I am missing a section on this page about minimal OCP version supported with Helm.

https://www.dynatrace.com/support/help/technology-support/cloud-platforms/openshift/other-deployment...

Looking for that information it seems that Helm is not supported for OCP 3.11 and Operator installation should be done as a regular one.

Have you used Helm for 3.11 OCP versions?

Thanks in advance.

Alberto.

1 REPLY 1

matthew_reider
Dynatrace Helper
Dynatrace Helper

Hi there. Make sure you are using Helm 3. It should work on OCP 3.11, though there is a bug prior to OCP 3.11.188 as documented here:

https://bugzilla.redhat.com/show_bug.cgi?id=1803163

Red Hat fixed the bug here:

https://github.com/openshift/origin/pull/24540

And you can make things work properly (if you are on an earlier version) by deleting this line here:

https://github.com/Dynatrace/dynatrace-oneagent-operator/blob/v0.7.0/deploy/openshift.yaml#L487

Hope that helps

Note: we are adding this to our help pages shortly.