cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How to DT_CUSTOM_PROP for JBoss

thaneswaran_bal
Newcomer

Hi,

We are trying to enter DT_CUSTOM_PROP to JBoss JVM. But OneAgent is not picking up the values.

Please help!


Thanks,

5 REPLIES 5

ChadTurner
DynaMight Guru
DynaMight Guru

are you in the correct working directory? also what file are you adding that data into? Keep in mind, depending on the file you are updating the oneagent will need to be recycled and possibly the service (Depending on that file).


hostcustomproperties: only requires a oneagent recycle - read more about it here: https://www.dynatrace.com/support/help/how-to-use-dynatrace/hosts/configuration/define-tags-and-meta...

DT_CUSTOM_PROP requires the service/process to be restarted

-Chad

We added to the system properties like this:

We can view this entry in the JVM argument but DT didn't pick up as Env custom meta data.

any advice? thanks

okay, well i do know that system properties can take a while to show up, Have you recycled the host/anent since setting the properties?

-Chad

yes both Oneagent and the JVM process was restarted. We could be able to see the DT_CUSTOM_PROP entry in the JVM argument. It shows up like this;

Not sure why there's a "back slash". Can you please confirm the entry into the system properties is correct? thanks.

I was trying to look for docs on DT site for JBoss entry, i was able to find one for TomCat but not for JBoss. If you have any link that will be very helpful as well.

Interesting, im not 100% sure where the issue is then, Maybe someone else on the forums will sport the issue. You also might want to open a ticket or support chat with Dynatrace on this.

-Chad