cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How to add Dynatrace as a library or as a framework for IOS Carthage instrumentation?

alejandro_herna
Organizer

Based on documentation depending on the iOS platform you will choose to add Dynatrace as a Framework or as a Library for IOS mobile app monitoring:

-For iOS 8+ apps, use the
framework.

-For iOS 6+ apps, use the static
library

I have seen for both Cocoapods and Manual instrumentation how you add Dynatrace as a framework or as a Library, but for Carthage I dont know how to add Dynatrace as a framework or as a library, how does it work for Carthage?


2 REPLIES 2

alejandro_herna
Organizer

I made a research and it seems that Carthage doesn't support iOS 7 or earlier. due to dynamic frameworks are only supported from iOS 8, so you will not have iOS apps with 7 or lower with Carthage. Dynatrace will be added as a framework for Cathage.