cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How to send StatsD from within a docker container to OneAgent UDP localhost:18125 port ?

Hello.

Between OneAgent versions 1.207.242 and 1.209.169 the StatsD listening port changed from UDP *:18125 to UDP localhost:18125. This broke our Traefick sending StatsD from within it's Docker container (running on Linux) to ip:18125 (cannot send to localhost:18125 nor to 127.0.0.0:1825 : this would loop back to the docker container as opposed to Docker host where the OneAgent run).

 

Potential solution : set the Docker container to --network="host" : not really an option : brakes completely the wanted isolation.

 

Are there any one using StatsD the same way ? I mean : from several different Containers, sending from within a Container to host OneAgent StasD listening port UDP localhost:18125 ? Any known solutions ?

 

Regards.

 

3 REPLIES 3

ChadTurner
Guru

OH NO! I would recommend opening up a support ticket as updates should not break current set ups. 

-Chad

Hello. Support feedback : Between OneAgent versions 1.207.242 and 1.209.169 the StatsD listening port changed from UDP *:18125 to UDP localhost:18125 is a design fix, it works as wanted. Regards.

Julius_Loman
Leader

Ports opened globally for services without any authorization such as statsd ingest are not a good idea.  At the moment you cannot modify the listening interface, but you can add an iptables rule and a sysctl config to forward the packets to loopback address.

TEMPEST a.s., Slovakia, Dynatrace Master Partner