cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How to use proxy server cloud foundry

sjoerd1
Advisor

Hi,

I'm using option 1 (create user provided service) to setup my cloudfoundry monitoring. In the network zone where this server is running, I can only connect to the internet through a proxy.

How can I configure the proxy server in the user-defined service?

cf cups dynatrace-service -p "environmentid, apitoken"

Problem I see is that during the restage of the app, it runs into a timeout when connecting to the dynatrace serverurl.

3 REPLIES 3

sjoerd1
Advisor

Now with setting the option https_proxy it seems that something changed in the behavior, but still I'm getting timeouts.

hayden_miedema
Inactive

Hi Sjoerd,

I am not sure if it is supported for CloudFoundry/PaaS agent approached, but with full-stack agents the parameter to use a proxy is 'PROXY'. See this link: https://www.dynatrace.com/support/help/installatio... under the supported install parameters section.

That being said, I would suggest changing your 'https_proxy' value to 'PROXY'. I am not sure if it will solve things, but worth a shot.

Regards,

Hayden

sjoerd1
Advisor

Hi @Hayden M., Thank you for your reply!

I also found that part about putting the PROXY as attribute, but that didn't help me. When I changed it to https_proxy, I also added:

cf set-env dtest https_proxy "https://myproxy:8080/

And after that I saw a "proxytimeout" when restaging (proxyconnect tcp: dial tcp 10.x.x.x....:i/o timeout).

After checking with the PaaS team, I found that they forgot to open a firewall towards the proxyserver, so that this could anyways never work.

Still, I think with setting the https_proxy as shown in my screenshot, the download of the PAAS agent should work.

I'll report back when the proxyserver firewall change has been done....