cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How to view tagged web requests on Dynatrace SaaS?

blush
Newcomer

I am not seeing the Tagged Web Requests dashlet on Dynatrace SaaS.

The real problem is viewing test run requests and grouping them for performance analysis. If there is another way of doing this -- without tagged web requests like in AppMon -- that would help!

For reference this is how the test was configured:

https://www.dynatrace.com/support/doc/appmon/integrations-and-extensions/integration-with-web-load-testing-and-monitoring-tools/

3 REPLIES 3

andreas_grabner
Dynatrace Leader
Dynatrace Leader

Hi there

I did a Performance Clinic on "AI Supported Performance Testing" where we show how to integrate Dynatrace with Load TEsting tools similiar to what we have with AppMon. Here is the video: https://www.youtube.com/watch?v=kwH64up-UAs&index=...

I also wrote the following blog post that explains the same concept. It shows how to configure Request Attributes and how you can then analyze the data based on Load Testing Names: https://www.dynatrace.com/blog/load-testing-redefi...

Another interesting youtube tutorial could be "Basic Diagnostics with Dynatrace" where I show how you analyze certain timeframes of data to identify hotspots or areas that can be optimized: https://www.youtube.com/watch?v=OEGk4JN9wDg&index=...

I hope this helps

All the best

Andi

blush
Newcomer
,

Thank you Andreas!

Gavin from DT shared with me a YouTube link also:

https://www.youtube.com/watch?v=kwH64up-UAs&t=2060s

Starting at ~48:30 Andi shows how these look in the
Dynatrace UI.

Starting at ~50:00 Andi show the configuration steps
to pull the request attributes.

blush
Newcomer

Hey @Andreas G.,

Thank you again! I'm almost through the video.

I can see the Tagged Web Requests in Appmon when I create a Dashlet and on SaaS I can see the Web Request Attribute in a drop down menu after I setup a custom rule. But when I try to add "Load Test XX" rule to the apache services it says that "The selected request attribute hasn't been seen on this service". How is this possible if Appmon detects the header?