cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Merge services using API, rules doesn't work

SROLE1
Newcomer

I have tried to merge the services which are belongs to one process group, same context root and same application id but different web server name. I tried to valueOverride for server but rule doesn't get affected. Please suggest below is the rule

{

"type": "FULL_WEB_REQUEST",

"managementZones": [],


"name": "SOA-XXXX_Merge",

"description": "Merge the SOA -XXXX service",

"enabled": true,

"conditions": [

{

"attributeType": "CONTEXT_ROOT",

"compareOperations": [

{

"type": "EQUALS",

"negate": false,

"ignoreCase": false,

"values": [

"/soa-infra/services/default/XXXX"

]

}

]

}

],

"applicationId": null,

"contextRoot": null,

"serverName": {

"valueOverride": "ABCD_WebServer"

}

}

6 REPLIES 6

Julius_Loman
Leader

It looks valid. Are you sure you are comparing to a good value in your condition and you have a good type (FULL_WEB_REQUEST)?
Just a reminder - it is applied only for new requests from the time the API detection rule has been applied.

Thanks for your help,

Actual problem is, someone already created the rule to change the contextroot from it's original value. So rule created is not matching the value provided for contextroot, as the original value is something else.

I have increased the order and updated the original contextroot value and it did worked.



SROLE1
Newcomer

I am comparing the Context_Root value as exactly showing in metadata of service. Also kept under observation for couple of days which turns some more request to receive.

DId you try to replace EQUALS to STRING_EQUALS ? I did not notice it at the first sight. Context root is a string, so I guess STRING_EQUALS should the right compare operation to choose.

I tried to change STRING_EQUALS but it is automatically changing value to EQUALS. Even i tried to create new rule but same once I submit request then value is auto changed to EQUALS.

Below is service type and technology, where i am trying this rule. Hope it supports

Service typeWeb request service
Service main technologyOracle WebLogic