cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Metric values change between Old and New Timeframe Selector

skirkham
Newcomer

When we were reviewing "Composite metrics across response times" for a particular web application on a recent group call it was noted that one of my colleagues had different values to what I was seeing, everything was identical in terms of filters, dates and times etc but the one thing that was different was the version of the Timeframe Selector - I was using the new one, they were using the old one. When we switched backwards and forwards between the two, the figures changed but it was just the composite metrics that changed all the other values seemed to stay the same.

Whilst these changes weren't significantly different it did raise a couple of questions from the group. So does anybody know why these two selectors produce different figures and if so, which is the accurate version?


Thanks

6 REPLIES 6

piotr_lewandows
Dynatrace Newcomer
Dynatrace Newcomer

hi Simon,

I work on timeframe selector. There should not be any difference in data when switching between old and new timeframe selector.


Perhaps you found a bug.

To better tackle the issue, could you help us with reproducing it:

  • Could you provide exact timeframe that causes issues?
  • Does it reproduce on any timeframes or just specific one (custom?)?
  • Does your colleague work in the same timezone as you?
  • Does it reproduce with more colleagues or is it this only person?
  • Is it on all screens or only single one?

I have just seen a case that is very similar to this. It's with synthetics. My colleague and I work in the same timezone, I use the old selector and he uses the new one.

When we see the last two hours, which should be between 09:00 and 11:00 he sees from 08:00 to 10:00. The values are the same, because it's the last 2 hours.

But when we do a graph for say yesterday, values are different for me and him. Both users have no configured timezones, so I imagine it might be grabbing the timezone somewhere else?

Thanks for writing up. We found some differences between classic and new selector when sharing links between different time zones. We work on fix.

The fact you're in the same time zone makes it more intriguing. Could you write in which time zone you work together? I'll try to reproduce.

We are both in Portugal, WEST.

We have managed to figure out that one image that was done last Friday and that he saved is in Portuguese time. So the shift/Bug seems to have occurred in the last 2/3 days, maybe due to 1.192?

In the meantime, we have also discovered that it differs by browser. He's a Firefox user and in Firefox the time is wrong. But on the same machine, logging in through Chrome gives a correct date. But, I'm also a Firefox user and I don't have that problem. We checked and have the same date/time settings. Quite confusing...

piotr_lewandows
Dynatrace Newcomer
Dynatrace Newcomer

Update: Since Dynatrace v198 we've made couple of improvements for sharing timeframes between timezones (especially values chosen from calendar).


Timezone information is gathered from Operating System of the user.