cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Multiple host properties with the same key

grechnev
Participant

As stated in the oneagentctl guide there is a possibility to have multiple host properties with the same key:

"It is allowed to define properties with the same key but different values"

https://www.dynatrace.com/support/help/shortlink/oneagentctl#custom-host-metadata

But when I do it, I see only ONE environment custom host metadata property (the last one). See the following screens:

Is it a bug?

If not, then why does such possibility exist in the OneAgent cli?

6 REPLIES 6

ChadTurner
DynaMight Guru
DynaMight Guru

Have you recycled the oneagent? also host properties might take a little while to update, Id restart the oneagent service and check back in a few hours

-Chad

Yes, I have restarted OneAgent. And I had been waiting for one day before I made this screenshot.

can you get the properties file and move the lines together so there is just a space between them? thats how we have it:

Software=GitLab Software=GetLabCE

I am curious if you change the name to Software and Software_2 to see if it shows up. Our Set up name Name_1=X Name_2=X

-Chad

I don't use and don't have any hostcustomproperties.conf files at all, because I set custom properties via command line. As you may know it is the recommended way for doing this since OneAgent version 1.189.

If I set different property keys everything works properly - I see all the properties in the UI. But it is not the case I described at first and tring to debug.

okay, you might want to reach out to chat support to ensure that the support article that you read is correct where you can have the same key - if that is correct, then it might be a bug that they need to review

-Chad

Tomasz_Gajger
Dynatrace Pro
Dynatrace Pro

Hi Max,

This is a bug in oneagentctl input validation and help pages alike. Setting multiple properties with the same key is not allowed and would result in just a single one being displayed, as you have observed.

We'll be fixing this in one of upcoming releases.

Thanks for making us aware of it.


Regards,

Tomasz