cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

New ProcessGroup is getting created after each deployment for nodejs docker

aftab_alam
Organizer

Hi All,

We are seeing new processGroup getting detected each time we do a deployment. We started seeing this behavior 2 weeks ago in our dev enviroment.

earlier OOB processgroup detection was working for for us in each enviroment as we group process by ENV_NAME varible as well.

I am not sure if this is due to any recent update form dynatrace side? how do we fix it so that we always get one processgroup->Services so that we can use abnormally detection and baseline feature effectively.

3 REPLIES 3

aftab_alam
Organizer

I see this issue with Java process as well

JamesKitson
Dynatrace Leader
Dynatrace Leader

The screenshots you have posted look to be showing services, not process groups. Could you post your technology overview to verify that new process groups are actually be created and not just new services? New process groups would lead to new services showing up since process groups are service boundaries though so it could still be an issue of new process groups being created. If you post that and any custom service rules that may help. Regardless, if this started showing up without making any changes you may want to reach out to support so they can investigate with you. Otherwise I would wait to see if anyone can provide additional input here. I would expect those all to be under one process group if that is your only custom PG rule.

michael_kopp
Dynatrace Pro
Dynatrace Pro

We would need to see the properties section of the process group. It might have something to do with the image name and the docker version scheme