cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

No CPU or memory metrics available for docker containers

moritz_becker
Participant

I am using Dynatrace SaaS to monitor dockerized services. When I select a host, Dynatrace shows me all the containers running on the host. But when I select a container, no CPU, memory or traffic metrics are available.

In the title it says 'Docker containers extension is enabled, but is not yet fully running. Data below may not be complete'. This sounds to me as if I needed to configure something for the metrics to work. Can you point me into the right direction?

6 REPLIES 6

Lukasz_Wrona
Dynatrace Advisor
Dynatrace Advisor

Hi.

The per container performance data is retrieved directly from Docker Daemon socket via the 'docker stats' API call. Please kindly go to Settings -> Monitored technologies and look for 'Docker containers' Dynatrace plugin. If it is marked red, expanding it will provide information, why data in question is not extracted.

The first step in diagnosing is usually to confirm that the 'docker stats' call on host in question provides the data (and in timely manner). If this works properly, please kindly open a support ticket - we can't answer more without knowing your tenant id, as there are multiple variables in place (Linux/Windows, permissions to Docker socket, Docker version and so on).

suresh230591
Advisor

Hi Moritz,

Did this issue resolved for you , I am having the same problem.

moritz_becker
Participant

@Suresh K. @Lukasz W.

Docker containers plugin is displayed as active in my settings and running 'docker stats' on one of my monitored hosts returns the expected metrics. I will open a support ticket.

suresh230591
Advisor

Hi ,

the docker container plugin show below error under monitored technology.
Error (getpwuid(): uid not found: 10009) for: host_name

@ Moritz B Did the issue resolved for you?

Looks like a bug, please open a support ticket.

moritz_becker
Participant

Hi,

in my case the lack of support for Alpine Linux seems to be the issue. The Dynatrace support told me that that Alpine Linux support is on their roadmap and the resource display should work once this feature is available.

@Suresh K In your case it is probably a different issue.