cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

OHS calls backend weblogic application/services and high response time seen only in the mod_weblogic plugin

Imran_Jamadar
Visitor

We are seeing high response time on mod_weblogic plugin and same is popping up even in response time hotspots. OHS forwards request to -> weblogic backend application, once the request reaches backend the response from backend is fast, Much of the time is spent in mod_weblogic plugin which is listed as other and is shown as self-time for mod_weblogic

 

I even checked for static content and this issue is coming even for simple image fetch. There are many idle web server threads and no issues observed  on resource exhaustion.

 

Attaching both scenarios for reference . Even raised support ticket but still no positive and concrete response

 

Imran_Jamadar_0-1616608396202.png

 

Imran_Jamadar_1-1616608490504.png

 

2 REPLIES 2

kurt_aigner
Dynatrace Pro
Dynatrace Pro

Hi Imran,
I just moved your question from the AppMon & UEM forum, which is one of our end-of-support classic products. Now you are in the right spot and I hope you get an answer soon.
Thx, Kurt

Julius_Loman
Leader

I belive this is a case of further investigation on your OHS in the weblogic module on OHS. Since based on the screenshots the requests to backend are executed at the end of the time of weblogic on the second example. Maybe a DNS issue?

I don't have any particular experience with OHS, but I guess there ist definitely an option for increased log verbosity of the mod_weblogic that may reveal the cause.

TEMPEST a.s., Slovakia, Dynatrace Master Partner