cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

OneAgent Installation on Kubernetes using Daemonset versus Operator

aurora
Newcomer

Hi all, Can someone explain me why installation of OneAgent with Kubernetes version 1,9 uses Operator while lower version uses daemonset?Thank you.


1 REPLY 1

jonathan_schull
Dynatrace Advisor
Dynatrace Advisor

Hi Ma,


OneAgent installation with the operator is preferred as it will allow the agent to be automatically updated. The Operator still uses the daemonset but it is handled for you once the operator is installed. Unfortunately the operator only works with Kubernetes version 1.9+, so for versions 1.8 or lower you will still need to manually deploy the Daemonset.


You can read more about the OneAgent Operator here: https://www.dynatrace.com/support/help/technology-support/cloud-platforms/openshift/installation-and...


Cheers,

Jonny