cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

OneAgent Tries to Connect to Cluster Instead of Security Gateway

We have a Managed environment with two security gateways installed. We downloaded the Windows OneAgent installer after standing up the security gateways, so the config files should contain thoe settings for those gateways. However, when finished the installer displays this error window.

The Agent is trying to connect to the central cluster, but it cannot since the firewall rules will not let it. It should instead be trying to connect to one of the two security gateways in the environment on port 9999.

Does the agent need to connect to the cluster once before running, or are we doing something wrong in the installation?


2 REPLIES 2

JamesKitson
Dynatrace Leader
Dynatrace Leader

No need for the OneAgent to connect to the cluster directly - as you said the installer should provide it with a list of endpoints when it first gets installed. I would double check the ActiveGate is connected and then double check that the installer you download has the ActiveGates in there (you should be able to search for it). I'd definitely try and re-download the installer from the cluster first before digging any deeper. The only time I had to troubleshoot a case like that is when the installer was downloaded before the ActiveGate was connected.

James


We tried downloading the OneAgent installer after the ActiveGates were installed, but we're still seeing the same issue. The Agent is also not showing up under the connected agents in the environment.

Here's the order we of installation we followed:

1. Install DT Cluster node.

2. Create an environment.

3. Go to environment.

4. Download Environment ActiveGate and install to two hosts.

5. Go to Add a Host. Download installer.

6. Run installer on targeted host.

As far as I can tell from documentation and experience, this should be enough to get a OneAgent up and running. But we can't get it to connect even after modifying the ruxitagent.conf file to only have the ActiveGates as endpoints and restarting the service.

EDITED TO NOTE: The above attempt at modifying ruxitagent.conf failed because the file is generated dynamically at runtime. However, we also tried installing the OneAgent via command line using a SERVER parameter, but this also failed. We did get it to try to connect to an ActiveGate though. So that means that something is wrong with communication between oneagent host and AG on port 9999 then.