cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Python Framework Being Upgraded to 3.8

See below doc for reference. Starting with OA and AG version 1.231 dynatrace will be upgrading their python framework to 3.8, from 3.6. It is noted that you can experience issues with data not being collected if you don't upgrade the extension to a newer version that is prepared for 3.8. Within our organization pushing out newer versions of AG extensions and ensuring python 3.8 is installed on all of them is not a problem. The work comes in play with the OAs, mainly due to upper level approval, pushing out a newer version isn't the issue.

 

We utilize the Generic Command extension on 2k+ hosts. I've done some testing with a host that does not have python 3.8, only 2.7.5 and it works fine before version 1.231 plus when upgraded to 1.231. Just trying to get some clarification on how this all works. I was expecting that version 1.231 OA will be using python 3.8 and that if you don't have that loaded on the machine then the extension will fail to collect data but that does not seem to be the case.

 

https://www.dynatrace.com/support/help/extend-dynatrace/extensions/python-migration

3 REPLIES 3

pahofmann
DynaMight Leader
DynaMight Leader

Active Gates and OneAgents bring their own Python runtime for Plugin Execution, so there is no need to install your own version of python.

 

You should make sure that your plugins runs with Python 3.8, before the Active Gates / OneAgents get upgraded to Version 1.231, as the included Python will be upgraded to 3.8 with that release.

Dynatrace Certified Master, AppMon Certified Master - Dynatrace Partner - 360Performance.net

Thank you pahofmann for this information. I've since upgraded our AGs to 1.231 and for the most part everything continued to work fine. We use the IBM MQ AG extension and that one did need to be upgraded along with the Citrix OA extension after upgrading to 1.231 for the OA but that is about it. Good to know we don't need to manually push down python 3.8.

AntonioSousa
DynaMight Leader
DynaMight Leader

There's also the other way around: installing extensions developed withing the 3.8 version, but installing it in Activegates that are behind 1.231?

Antonio Sousa