cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Redis Service Name - Rename

benjamin_mullan
Contributor

Not sure if there was an update or that implementing Azure monitor data has caused my issue.

 

I have a set of dashboards that measure Redis metrics but all the names have been set to "Redis" instead of the underlying process name and subsequently dropped the data as the name has changed.

 

I for the life of me cannot figure out how to automatically rename them back to their named instances

The calling services know the endpoint. Azure knows the name. Dynatrace has tied both the entities together.

 

There is even a target host but I cant seem to attach to it

 

benjamin_mullan_0-1655680172502.png

 

 

 

 

2 REPLIES 2

andre_vdveen
DynaMight Champion
DynaMight Champion

Hi @benjamin_mullan,

 

Did you set up any custom service naming rules to update the service name to match the underlying process name? If yes, are those still enabled?

 

If you didn't set any up, I guess you could set up service naming rules that look at the underlying process name and apply that to the service name.

Hello @andre_vdveen . Originally no service renames were set, it just "worked".

 

I cannot find a placeholder to produce the "azure name"

{Service:DetectedName} produces the service name "Redis" 
{ProcessGroup:DetectedName} produces nothing. 

As shown in my original post's image there is a Target host metadata on the Service it's self but the service rename dropdown does not include this option so it cannot be used.