cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

SetupHttpClient() is not instrumenting

jesper_plantene
Newcomer

Hi guys.

I have followed this guide https://www.dynatrace.com/support/help/technology-support/application-software/other-technologies/su... in order to setup instrumentation of our Xamarin.Forms app.

Currently, my app is tracing basic data to Dynatrace like count of users, crashes, version history etc.

I would like to have it trace HttpClient requests as well, but it seems like the autoinstrumentation is not working.

When I run Dynatrace.SetupHttpClient(httpClient) on the client, nothing happens. It seems like the special header is not even attached to the request.

If I perform manual instrumentation, as described in the guide as well, then it works though.

I would of course prefer to do it the simple way though.

I am running Dynatrace.OneAgent.Xamarin version 7.2.11

Any ideas?

4 REPLIES 4

nicholas_mcwher
Dynatracer
Dynatracer

Hello, Jesper.

Thanks for reaching out on this. You are absolutely right. I was able to reproduce the issue at hand and have a fix in place. We will likely release the new version of the Xamarin NuGet Package on Monday but depending on testing and such that date can potentially change. I will post another comment here whenever it is available for you to download/use.

I hope you have a nice weekend!
Nick

Thanks Nicholas. Looking forward to that!

Hi, Jesper!

I hope you had a nice weekend. The package has been updated to version 7.2.12 with the new fix as we mentioned here. https://www.nuget.org/packages/Dynatrace.OneAgent.Xamarin/ At your convenience, please update the package for your project and let us know if that resolves your issue.

Thanks in advance!
Nick

Hi Nicholas. I just verified that it works. Thanks a lot!