cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

The agentPath did not append to the JVM startup command

oolp_love
Newcomer

Some of my java app works as soon as it startup. But some of them does not work after it startup.

I checked that with `jps -lv`, I think the reason is no agentpath at the end of the startup command. Could you share what I can do to get the deep reason for the `agentpath` is not appended.


7 REPLIES 7

Julius_Loman
DynaMight Guru
DynaMight Guru

Dynatrace Oneagent does not add or modify any arguments for the JVM process. I'm not sure about the technical details, but I think it uses JVMTI for this. If some Java processes do not start after oneagent installation, be sure to check the Oneagent Java logs, logs from your application and stdout/stderr of the Java process (if applicable).


TEMPEST a.s., Slovakia, Dynatrace Master Partner

I did not found any logs in the stdout about oneagent.

You mean that oneagent startup a daemon process, and change the startup command when the java process startup for appending the agentpath at the end. Could you confirm with your technical developer about this?


oolp_love
Newcomer

I did not found any logs in the stdout about oneagent.

You mean that oneagent startup a daemon process, and change the startup command when the java process startup for appending the `agentpath` at the end. Could you confirm with your technical developer about this?


Joe_Hoffman
Dynatrace Leader
Dynatrace Leader

King, Can you clarify the issue. Are you reporting that some of your Java apps will not run when OneAgent is installed on your host? If this is true, then I suggest you open a support case.

OneAgent hooks itself into the JVM differently than the approach used by AppMon. You will not see "agentpath" on the java command line.


oolp_love
Newcomer

@Joseph M. H. No, I am pretty sure. Oneagent append `-agentpath` at the end of the command.

I can see it when I checked it with `jps -lv`. But some of service is not appended.


Joe_Hoffman
Dynatrace Leader
Dynatrace Leader

King, Can you clarify my first question: You stated "... but some of them does not work after startup". Are you saying that your JVM is not running correctly after adding Dynatrace OneAgent?


yes, you can see the picture in the previous reply.