cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unsupported OneAgents

ADPaoloni
Mentor

Hi!

We have a bunch old oneagents still deployed (vs 1.135). We have Managed 1.176. I thinks the oneagent support is 9 month olds. What happen if we upgrade the Cluster to a new version that don't have the support of the oldest agents? Does the agents keep communicating? or stops/show as unsopported?




6 REPLIES 6

Julius_Loman
Leader

I think agents are officially supported 1 year from the release and I think this time is just a support period. (Support tickets on problems affecting old agents can be refused by the support team).


TEMPEST a.s., Slovakia, Dynatrace Master Partner

Yeah, what i'm curious is.. if we update tomorrow to a newer version and the deployed agents don't have any more support. Would they keep working?


I'm pretty sure it will work.


TEMPEST a.s., Slovakia, Dynatrace Master Partner

The_AM
Dynatrace Pro
Dynatrace Pro

Hi Dante,


The older agents will still communicate with the later versions of the cluster. Because that way they can automatically retrieve and apply the latest update package according to the update policy set for hosts - without any need to re-install agents.

The support period is 9 months for standard support and 1 year for premium. It just means if you run into any problem with an agent, you'll likely be asked to update to a supported OneAgent (i.e. latest) for our support teams to assist you. Just curious, is there some reason the agents were not updated in your case? was it set by policy in your environment preferences or some other reason?

The only situation where the agents will not be able to communicate is if a newer feature of Dynatrace was enabled on your cluster which required a minimum agent version to be met to enable the feature for compatibility reasons. These have to be enabled by the support teams, so if this were the case, you would have been made aware of the need to update your OneAgents. And once that happened, any older OneAgents in the environment would no longer communicate.


Andrew


Regards,
Andrew M.

Support for some legacy platforms ended with Oneagent 135 (such as PHP5.x), that's probably a reason why some people still have those versions running.
TEMPEST a.s., Slovakia, Dynatrace Master Partner

Hi @Andrew M. ! As @Julius L. commented, is legacy Support for those techonologies. PHP 5.X.

Unfortunately, the support is not willing to update this technology to a new one, in fact this are the only agents 1.135 and that is the only reason. Searching the forums also is the only reason to install that version AFIK.

We are at 1.176, so the fact that still works and communicate wouldnt change at 1.178 (unless there is a minimum agent version to be met (Like in Session Replay or something like that)