cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Visual Studio Loadtest is not detected under Application

vitaliy_rumyant
Newcomer

Hello,


We use Visual Studio loadtests to measure performance of our web-app.
Those loadtests are comprised of webtest that simulate real user activities such as logging on and off, taking on activities inside web-app, importing images etc.

When I manually do these steps in regular browser - they are detected and show up under Application monitoring e.g. logging into the application.

However when I am submitting webtests or running loadtests from Visual Studio - they do not show up under Application monitoring e.g. same login into the web-app.

I can see the OneAgent injected monitoring tag in server responses for request sent from Visual Studio.
Our webtests also leverage JavaScript in application.

There's similar problem already described but it didn't handle javascript in loadtests it seems and that was the issue.



BR,
Vitaliy.

4 REPLIES 4

Radu
Dynatrace Pro
Dynatrace Pro

Hi Vitaliy,


I'm not sure if your use case is supported with it not being a real browser and all, but since you're able to run JavaScript as part of the test and you are seeing the JavaScript tag injected by the OneAgent in the server responses then maybe we can troubleshoot this.

Do you have a view of all network requests coming from the test? You should be able to see requests initiated by your page to /rb_xxxxx ?

These should appear as initiated by the JS injected by the OneAgent. This is essentially the frontend data being sent back as a beacon signal to the Dynatrace platform. Without this loop happening you won't be able to save data in the platform.


Hope this helps,

Radu

Hi Radu,

Thanks for your comment!
Let me reiterate to confirm that I understand it correctly:

  1. OneAgent service injects monitoring JS tag into all server responses
  2. Payload in these JS tags are processed in client browser when user accesses web-app
  3. Monitoring data is then being sent from user browser to Dynatrace servers and appear on dashboards

So the process is (1) OneAgent -> (2) Server response (JS Injection) -> (3) Client Browser (JS execution and sending data to Dynatrace) -> (4) Dynatrace servers.

The issue as I see it is that Visual Studio that receives server response instead lf (3) Client browser does not process JS payload and so Dynatrace doesn't get any data from it.
That's because VS isn't a real browser and isn't supposed to do anything with server responses (it doesn't even try to render them).

Would you say that this is correct?


BR,
Vitaliy.

That is spot on! 🙂

Thanks, I appreciate the help.