cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Warning in OneAgent Log File: ruxitagent_host_xxxxx.log

siewsphone
Frequent Guest

Hi to All the DT Gurus,

 

One of our servers facing a strange OneAgent CPU Usage issue, it looks like the oneagentos.exe will have 100% CPU spikes every hour and last for a few minutes.

 

After I investigate the logs files, I came to this warning and I am not sure what does it means.

 

May I know anyone here who face the same issue before?

 

Thanks in advance.

 

====================================================================

 

2022-03-18 14:37:45.043 UTC [0000a98c] info [native] Regrouping processes due to declarative configuration changes
2022-03-18 14:37:45.093 UTC [0000a98c] warning [native] Detected process added to groups twice, processes:420, grouped processes:422
2022-03-18 14:37:45.108 UTC [0000a98c] warning [native] Update metrics took: 54890 ms, collecting host metrics: 19 ms, collecting disk metrics: 13 ms, collecting network metrics: 3 ms, detecting processes: 88 ms, updating network agent metrics correlator : 0 ms, filtering docker bridges: 0 ms, host events generation: 0 ms, grouping processes: 54752 ms, handling blocklist: 0 ms, group events generation: 1 ms, updating aggregator: 2 ms, resource exhausted events: 0 ms, updating host info: 12 ms, deployment changes storing: 0 ms, logging monitored processes: 0 ms, closing child processes: 0
2022-03-18 14:37:45.108 UTC [0000a98c] warning [native] Timer task 'updateMetrics' took 54892ms to execute (which is more than half of the timer's period)
2022-03-18 14:37:50.365 UTC [0000a98c] warning [native] Detected process not added to any group, processes:254, grouped processes:253
2022-03-18 14:38:00.362 UTC [0000a98c] warning [native] Detected process added to groups twice, processes:273, grouped processes:274

 

 

4 REPLIES 4

andre_vdveen
DynaMight Pro
DynaMight Pro

Hi @siewsphone,

 

If you haven't already, I'd say the best course of action here would be to open a support ticket with Dynatrace.

Dynatrace Certificated Professional - Mediro ICT, South Africa

Sujit
Helper

@siewsphoneRe-install if that works it seems OA got corrupted some how.  if that doent work then you should go with support ticket which is suggested by Andre too.

 

Thanks,

Sujit

Dynatrace Certified Professional

siewsphone
Frequent Guest

Thanks all, currently working with Dynatrace support on this issue and they also have a problem identifying the root cause.

rastislav_danis
DynaMight Pro
DynaMight Pro

Did you setup any declarative process groups ? As i see "Regrouping processes due to declarative configuration changes" line in your log.