cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

WebHook: disable the proxy just for some of them

y_buccellato
Advisor

Hello community people!

We are about to integrate Dynatrace with a third party component (Service Now). For that we need to configure a webhook that will pass via proxy.


On the other hand I have at least one other custom made integration that use webhook from Dynatrace but doesn't need to pass via a proxy.


In order to setup my custom made integration I previously setted the property

proxy-off = true

in [http.client.external] section of my config.properties in Dy Servers.


Is there a way to selectively choose what webhook must go via proxy and what other webhook must not? (as in my case: the one for Service Now must, the one for Custom Integration must not)


Thank you for your time

12 REPLIES 12

Radoslaw_Szulgo
Dynatrace Guru
Dynatrace Guru

Try adding additional property to the section:

proxy-non-proxy-hosts = *.company.corp.org


To include a number of hosts, separate them with the | characters. You can also use an asterisk * to replace any string. For example: proxy-non-proxy-hosts=*.london.dynatrace.com|my.corp.org


I haven't documented that yet, but I'll.


Senior Technical Product Manager,
Dynatrace Managed expert

Hi Radoslaw, thank you for your time and answer;


I'm not so sure about what you wrote me, the only piece of documentation I can find is on proxy config when it comes to test resource via Synthetic:

Set up a proxy for private synthetic monitoring


but here I'm referring to proxy config when I need to send payload via webhook with Dynatrace to another Ip/host/application:

Webhook URL in custom Integration





Yes, I got you.

So you wrote to control the proxy settings you modify config.properties file on each Dynatrace Managed node. That's proper way to do it. Instead of turning off the proxy by adding "proxy-off" = true you should add what I proposed. Then restart the node. Repeat for each node. Let me know how it works.

You need to have your Dynatrace Managed at latest release: 1.198.

Senior Technical Product Manager,
Dynatrace Managed expert

@Yann Buccellato worked ?

Senior Technical Product Manager,
Dynatrace Managed expert

Hi Radoslaw,


I have tried your solution:

in the custom.settings

.removed the line proxy-off = true

.added the line proxy-non-proxy-hosts= 123.mycompany.it (this one will not pass via proxy then)

.saved my custom.settings file

.restarted the node.


The solution has not worked (custom webhook was still working escaping the proxy but the Service Now webhook wasn't working cause it wasn't mde via proxy as we intended)


What I notice is this:

after I restart the Dy node the new property (proxy-non-proxy-hosts) was added on top of the other properties before in /server/conf/config.properties but the old property is not be erased from that file (so proxy-off = true was still there even if I erased it from custom.settings)

So I decided to add the proxy-off = false with the other property custom.settings = 123.mycompany.it

The config.properties changed accordingly after the restart. So now I'm in the reverse situation: the Service Now webhook work but the custom one doesn't.


Is there a way to erase the proxy-off property from the original config.properties file by modifying the custom.settings file? (I also tried to comment it out [#proxy-off] or to not put a value at all, but it's not working)

Thank you


that might be a bug.. Can you please create a support ticket or contact with our Dynatrace ONE via help chat?

Senior Technical Product Manager,
Dynatrace Managed expert

I will do and I will keep you updated

Hi, I opened a ticket to the support; they say they are currently aware that you cannot decide which webhook goes with a proxy and which not.

So apparently there is no solution to this; I ask them to double check based on this community thread

If there is no solution I'll speak with my SOC team a redirect my custom Webhook from proxy to the endpoint.

Thank you

If you have any news on the subject let know please.

If the solution will be soon in the documentation I will wait for it,

thank you!

Just found this thread as I'm in similar situation.... mixing webhook URLS with proxy and non-proxy. Were you able to find any other mods that worked in the config file?

Looks like they finally added this feature in 1.206 officially!

https://answers.dynatrace.com/comments/245979/view.html

v-shabeer_ali
Visitor

Dears..

This link doesn't work. 

https://answers.dynatrace.com/comments/245979/view.html

Please update the correct one if anyone have.