cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Webhook integration: Can you bypass the proxy server for local Addresses

AmitChiba
Guide

We have configured our Dynatrace Managed Cluster to use a proxy server to connect to Dynatrace Mission Control, and this works as desired. We are now trying to integrate Dynatrace Managed to our local Ticketing tool using WebHooks. Our ticketing tool is internal and as such, has a local IP address. When trying to integrate, it seems as though Dynatrace tries to use the proxy and this fails.

Is there any way of specifying that local IP addresses should be ignored?

12 REPLIES 12

AmitChiba
Guide

After trying numerous options, I finally managed to get this to work. The following solution worked in my environment (OS = RHEL):

- Navigate to $DT_HOME/services

- Make a backup of the server.sh file

- Edit the server.sh file and add the following to the "export" section

export http_proxy=http://<proxyserver>:<port>

export https_proxy=$http_proxy

export no_proxy=".<yourdomain>"

- Save the file and recycle your Managed Environment

Is this still valid for recent Dynatrace Managed sprints? Is has no effect in any environment I've tried. And the cluster management console still does not have any option to specify proxy exceptions.

It seems a bit like this was a secret 'feature' of Managed. If you're still using it Amit C does it still work? It seems even Dynatrace support can't confirm if this would work!


Eddie, use the solution by Christoph below.


The problem with Chris's solution below is it applies to all the webhooks - I want to be able to config some of our webhooks to use the proxy and some not. Or am i misunderstanding and it is possible with Chris's solution?


This is not possible I think.
There are least two options I can think of in this case:

  • be nice to the network/security team to allow direct connection without proxy to all services 🙂
  • use a proxy tunnelling mechanism to expose the remote webhooks via proxy as local endpoints. For example use socat or proxytunnel. (http://proxytunnel.sourceforge.net/), If you have several foreign webhooks you will need to setup socat/proxytunnel for each one.

I am no longer using the above solution. I eventually went to our Security guys and asked them to redirect traffic to the specific IP address for the Webhook back internally. I havent had an issue since.


markus_reusch
Inactive

Forgot to mention that an update could overwrite this script and the settings are gone. One more reason to integrate it somehow.

christoph_kopf
Inactive

Hi there, the following configuration of /opt/dynatrace-managed/server/conf/config.properties does the trick. It then disable the proxy for all WebHooks.

[http.client.external]
...
proxy-off = true

- Christoph

jiji_joseph
Contributor

None of these solutions work acros upgrades. The upgrade process will remove all changes you made these files. This is the case for the solution mentioned by @Amit C and @Christoph K. Anyone found a method that would work consistently across upgrades?

Jiji Joseph