cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Would Agentless Monitoring Conflict with Standard Monitoring (OneAgent standard installation in web server)?

I've successfully installed OneAgent in the web server, and I can see purepath from the front-end to database-tier.

The only thing is that no application data is visible. Using 'view page source' and the browser developer tools, I can see that no ruxit.js is injected, and also no X-dynatrace header is present.

Just when I was about to ask clients to check on firewall and/or load-balancer and/or any network applicances that possiblt stripped off the header and the js, clients told me they RemoteDesktop into the web server and accessing the webpage locally there by means of /localhost. And even with this local way of accessing, still we don't see ruxit.js.

As I am running out of option (please tell me if you have suggestion on the option I haven't try), I am thinking of doing manual injection.

But I am not quite sure if it would cause any problem or not, as OneAgent is already installed in the web server. (For example, do I need to uninstall OneAgent in the web server or disable monitoring on web server?)

So, better to get some suggestion here first, before I propose to clients about this (not to mentioned I have to propose to them to let me deploy Public SecurityGateway)


3 REPLIES 3

vivek_bhandari
Newcomer

Dear Wai,

OneAgent has the tendency to overwrite/stop any and all 3rd party monitoring agents when it is installed and the service starts to run on any server.

If you are not able to see your Web App data, I would recommend re-verifying the prerequisites and re install the OneAgent

If the problem persists, please consult with DT support.

Warm Regards

Vivek


Hello Wai C. ,

i suggest you to troubleshoot why agentless RUM is not working for your case(any incompatibilities with webserver??)

As a workaround , please try to do manual injection as per below URL: if this works , it will confirm that oneagent was not able to enable UEM . you can post further details for us to check for further "WHY" questions.

https://www.dynatrace.com/support/help/user-experience/real-user-monitoring/how-do-i-enable-real-user-monitoring/

Thanks

Himanshu Mor


Problem solved, it was that the license doesn't has any DEM purchased and I forgot to check on it.