cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

modern nginx/openresty instrumentation with oneagent

rick_boyd
Mentor

Hi! Is there a workaround or plan to get newer builds of Openresty (Nginx) supported by oneagent? They are based on newer flavors of Nginx which are generally supported, but the instrumentation fails. currently i have to pin my openresty deployment to a very old version (Version 1.11.2.2 - 17 November 2016) in order to get instrumentation


5 REPLIES 5

steve_caron
Dynatrace Advisor
Dynatrace Advisor

Hi Rick, I think I'm currently facing a similar issue. Instrumenting Kong (based on Openresty) is failing. I have a ticket open for that. You are saying that using an older version of the OneAgent worked to instrument OpenResty?


no, i had to use an old version of openresty to get the oneagent to work. it's funny our kong instances are definitely good (we are on 0.10.3 i think)


Got it, thanks Rick.

The problem we are facing is with Kong Enterprise Edition 0.34-1v.

It is using Openresty version 1.13.6.2


rick_boyd
Mentor

bumping with enough characters to ok there we go


ChadTurner
Leader

Rick, have you had any progress with this? Here is the list of supported Tech and versions: https://www.dynatrace.com/support/help/technology-support/supported-technologies-and-versions/ If your technology or version is not supported, you can always put in a RFE and.or monitor the technology via agentless monitoring.

Granted this is an old thread, so were you able to monitor the technology? Did you have to go the Agentless route? do you have any tips/feedback for users who are looking to monitor the same thing?

-Chad