cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Active Directory Services 2.0 Extension - Metric Error

Anyone using the Active Directory Services 2.0 extension in their environment and have not modified it? If so are you getting the error below with the metric below


metric name:

Total DHCP requests/s

metric key:
func:com.dynatrace.extension.active-directory.dhcp.server.requests.persec.total


error when pulling up metric in metrics page:

Error reading metric data. - Description: Stored metric is invalid: Can not handle metric key 'func:com.dynatrace.extension.active-directory.dhcp.server.requests.persec.total' because the stored expression '(com.dynatrace.extension.active-directory.dhcp.server.requests.persec)+(com.dynatrace.extension.active-directory.dhcp.server.v6.requests.persec)' is invalid. No metric found using the Metric Id "com.dynatrace.extension.active-directory.dhcp.server.requests.persec". Stored metric is invalid: Can not handle metric key 'func:com.dynatrace.extension.active-directory.dhcp.server.requests.persec.total' because the stored expression '(com.dynatrace.extension.active-directory.dhcp.server.requests.persec)+(com.dynatrace.extension.active-directory.dhcp.server.v6.requests.persec)' is invalid. No metric found using the Metric Id "com.dynatrace.extension.active-directory.dhcp.server.v6.requests.persec". Metric Expression: (func:com.dynatrace.extension.active-directory.dhcp.server.requests.persec.total:splitBy():avg:auto:sort(value(avg,descending)):limit(10)):limit(100):names

I do see the below in the Log viewer when filtering for logs specific to the extension, I'm wondering if this could be causing the issue we are seeing

DEVICE_CONNECTION_ERROR:Cannot execute query: DHCPServer on device localhost: Exception occurred. (Invalid class ) [status code=38]; DEVICE_CONNECTION_ERROR:Cannot execute query: DHCPServerv6 on device localhost: Exception occurred. (Invalid class ) [status code=38]; OK:All queries;

1 REPLY 1

ChadTurner
DynaMight Legend
DynaMight Legend

@travis_anderson were you able to get this resolved? have you tried the latest version of the extension? If you were able to get this working could you please share with us what you had to do to get it working? 

-Chad