cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

ActiveGate Plugin Endpoing configuration error.

siteopsteam
Newcomer

We’re building custom ActiveGate Plugin. The plugin has been built successfully and deployed, after installation when I try to do Add endpoint configuration I’m getting error “Configuration error(Plugin doesn't exist on given host)”.

I’ve deployed the plugin via UI. What needs to be given in the endpoint? As per https://youtu.be/wbH2mpJIaog?t=1290 whereas for me it's not showing password filed. will this cause an issue here?

Attached the error screenshot.



2 REPLIES 2

jonathan_schull
Dynatrace Advisor
Dynatrace Advisor

Hello,


Can you check to see that the plugin is installed in the correct folder on the ActiveGate you selected?

  • Linux: /opt/dynatrace/remotepluginmodule/plugin_deployment
  • Windows: C:\Program Files\dynatrace\remotepluginmodule\plugin_deployment



We don't have access to those activegate servers, we've reached out to admins to manually copy it under /opt/dynatrace/remotepluginmodule/plugin_deployment. Now we're started getting a different error "Error(No module named 'elasticsearch') ". so we've updated the plugin.json file with install_requires.

I'm having a question here Do we always need to manually copy the .zip file (out put of build) and paste it under /opt/dynatrace/remotepluginmodule/plugin_deployment and also need to upload it from web UI?

won't deploy from web UI won't deploy in the active gate servers?