cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Activegate Plugin SDK broken/changes

r_weber
DynaMight Champion
DynaMight Champion

Hello,

I'm using a docker container with the AG and AG Plugin SDK installed for a very long time now.

I just updated the container with the latest AG and the latest plugin SDK (standard process that always worked in the past).

Now when building the plugin with it, it gives me this error:

r_weber_0-1662994754710.png

Suddenly it is looking for a properties.json file which it never needed before? I searched the documentation but couldn't find anything about it and why it is needed for build_plugin.

 

Any ideas?

Certified Dynatrace Master, Dynatrace Partner - 360Performance.net
8 REPLIES 8

AntonioSousa
DynaMight Guru
DynaMight Guru

@r_weber 

I use extensively properties.json with "plugin_sdk simulate_plugin", but have not ever found it with build_plugin...

Antonio Sousa

Yes, I believe there is something wrong with the plugin SDK version (latest one 1.247). I NEVER used properties.json in any of my active gate plugin builds, but suddenly "plugin_sdk" is asking for properties.json - failing if it isn't found and also failing if it is found and contains some properties...

 

Unfortunately I do not have an older plugin SDK available to test if it is the version ...

Certified Dynatrace Master, Dynatrace Partner - 360Performance.net

@r_weber,

Not sure if they are environment tailored? Doesn't seem to be the case. Have a 241 version if you are interested?

Antonio Sousa

No the plugin sdk is not environment tailored for sure.

Any way you can share the old sdk version? This is driving me crazy, used to be a 5min job to update my build env, but can't get it to work with the current SDK now 😞

Certified Dynatrace Master, Dynatrace Partner - 360Performance.net

Thanks for sharing the old SDK, unfortunately same issue.

Certified Dynatrace Master, Dynatrace Partner - 360Performance.net

r_weber
DynaMight Champion
DynaMight Champion

Not sure if this is intended but it seems although I installed the AG Extension SDK the "plugin_sdk build_plugin" command always tries to build a ONEAGENT extension and not an AG extension?

 

root@229ce6c8df31:/plugin# plugin_sdk build_plugin
Arguments=Namespace(deployment_dir=None, no_cert_ver=False, no_upload=False, plugin_dir='/plugin', server=None, token=None, token_file=None, verbose=False)
Starting oneagent_build_plugin

 

Certified Dynatrace Master, Dynatrace Partner - 360Performance.net

ben_davidson
Dynatrace Enthusiast
Dynatrace Enthusiast

Your Traceback message references a problem coming from the jsonschema package. This is a dependency of plugin_sdk. There was a change made in version 4.10.0 of jsonschema that seems to have broken several tools that depend on it.

 

For now, the best course of action is downgrade your version of jsonschema to <=4.9.1. Run the command:

 

pip install jsonschema==4.9.1

 

There is a more detailed set of instructions available here.

That did the trick! Thanks!

Certified Dynatrace Master, Dynatrace Partner - 360Performance.net