cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Why does the cisco extension not working on my ActiveGate?

gilgi
Pro

Hi All, 

 

Asking for your help. We have a manged environment running version 228. We have on a single environment ActiveGate which was automatically upgraded to version 227. I have enabled the cisco snmp plugin (version 224 was enabled) and we're trying to make it work but failed so far. I've started digging around and found the following:

1. In the log files we see the message that it cannot find dynatrace/remotepluginmodule/agent//config/extensions

 

2. When using the REST Api to retrieve the configuration The only event is "Failed to assign monitoring configuraion to Active Gate, fast check status: NO_SUITABLE_ACTIVE_MONITOR, reason: No Active Gates capable of handling given technology available"

 

Since there is only one active gate it is in the Default group.

 

Any hints?

Thanks, 

Gil.

5 REPLIES 5

david_lopes
Dynatrace Advisor
Dynatrace Advisor

As we discussed 1 one 1, the issue was that the Cisco Generic Device extension version 1.2.4 that you had installed has a minimum Activegate version of 1.228, while your Activegate was 1.227.

We are working on adding version 1.2.3 and prior to the Hub, so that you can chose an older version that is compatible with your AG, for the meantime I've provide you with the 1.2.3 zip file directly.

Version 1.230 of Dynatrace also provides a clearer error message when that happens.

Also keep in mind that the extension version "224" doesn't exist, the version can be seen on the interface as "1.2.4"

Hi David, just for my information i have the same problem.

If the cluster is in 1.228 the next version is 1.230.

It s the same for activegate, the next version is 1.229.

Does that means that the cisco generic extension is functional with activegate 1.229 so with Cluster 1.230?

 

Hi, that is correct.

Mike

Hi Mike,

thanks

gilgi
Pro

Installed 1.2.3 and waiting for the results. Thank you. That being said, I find it weird that an extension is uploaded to the hub when it's requirements are not available to customers. Active Gate 228 wasn't available even on saas when the 1.2.4 was released publicly to our instances.