cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

AMD installation - dependencies install Error

mmeraj
Inactive

Hi,



i am trying to install AMD version 12.01 on a Redhat Linux enterprise Server 6.4 (64bit). The Operating system was installed using the Kickstart file provided along with the AMD software. All the dependencies are installed.



Upon executing the ./up....bin of AMD Software installation package.. The below mentioned dependencies are missing and are required to be installed using the RHEL install media or from Internet. But each time a command is issue such as "./upgrade..... --install-deps-from-media or ./upgrade... --install-deps-from-net", a redhat linux subscription error is displayed and the dependencies are not installed and hence the AMD installation is aborted.



The dependencies installation has something to do with Registration or subscription from RHN or is it an issue from OS compatibility?

What If I get my system registered by RHN and a valid subscription is binding to the AMD server, will the dependencies get installed from Media or by internet.



Missing dependencies6-11-2013 2-05-01 PM.png

java-1.6.0-sun

perl-XML-Simple

xerces-c



I need to solve this critical issue ASAP since we have three upgrades lined up from next week and all of them will be migrated to RHEL 6.4 (64bit ) with 12.01 AMD version.



attached are the screen shots



Regards,

meraj.

7 REPLIES 7

mmeraj
Inactive

Hi..



Finally got the issue resolved by installing the dependencies manually.



Cheers (smile)_

Meraj

przemek_tafelsk
Inactive

Meraj,



The RHEL OS installation procedure in covered in details in AMD install guide.



And that includes 'Adding Missing Software After Red Hat Enterprise Linux 6Kickstart Installation' chapter, where thesethree missing software dependencies are listed.



Those components are missing because



(a) they are not part of the base server repository (the one included in RHEL installation DVD)

and

(b) JAVA - we do not re-distribute the package as part of AMD software bundle (upgrade.bin) as it's a 3rd party (Oracle) component.



Przemek Tafelski

Hi Przemek,



I try a lot of workarounds to make the AMD software get installed on RHEL 6.4 but in vain.



I just cannot get those dependencies install what so ever i try to do.



I was wondering if there is guide on how to install those dependencies.."not talking about AMD install guide" but some thing from

development team itself.



Regards,

meraj.

Hi Meraj,



I understand your pain.



For RHEL 5.x we do install all the packages with the kickstart, so that could be a possible workaround?



The fact that we do not install them for RHEL 6x is not a limitation on Compuware side, as Przemek has already explained.



Good luck!



Cheers,



Kristof

Meraj,



That is definitelly something our Support Team can help you with. There is nothing to do in here for development.



I can see you have a support case opened for this already (00767745). Please expect a call back soon from us.



Cheers,



Przemek

przemek_tafelsk
Inactive

Please see a short presentation how to obtain the missing dependencies for AMD installation on RedHat Linux 6 x86_64.
First you need to register on RedHat Customer Portal (RedHat Network) and then the rest is easy.

Once you have downloaded the rpm files, copy them over to AMD using WinSCP for example and install manually:

rpm -i xerces-c-3.0.1-20.el6.x86_64.rpm

rpm -i java-1.6.0-sun-1.6.0.45-1jpp.1.el6.x86_64.rpm

rpm -i perl-XML-Simple-2.18-6.el6.noarch.rpm

re-run:

./upgrade-amd-amdos6-x86_64-ndw-12-00-00-2506-b001.bin --list-missing-deps

AMD Installation and Upgrade Utility, Copyright (C) 2005-2012 Compuware Corp.

Installation version:      AMD 12.00.00.2506 with OpenSSL support
Installation architecture: x86_64
Installation type:         fresh installation
Installation started on:   Mon Sep  9 13:43:41 EDT 2013

No missing dependencies, it is OK to install AMD software

And now finally install the AMD software:

[root@amdprobe tmp]# ./upgrade-amd-amdos6-x86_64-ndw-12-00-00-2506-b001.bin

ps. You'd need WebEx Player to play the presentation.

inl00049_yoshid
Inactive

I'm in same situation and I can not find java-1.6.0-sun-1.6.0.45-1jpp.1.el6.x86_64.rpm on Internet. Can someone provide that rpm file?