cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

After reboot CAS only keeps10 days of data

henk_stobbe
DynaMight Pro
DynaMight Pro

Does anybody have a clue how this is possible? I can find no errors in the logging.

12 REPLIES 12

kristof_renders
Dynatrace Pro
Dynatrace Pro

Is there no data at all after 10 days? Or is there data in lower resolution than 5mins available?

By default, the CAS only keeps data in the highest resolution for a limited amount of time (10 days).

Data that is older than this 10 days, will be aggregated into a lower resolution to keep the database size on a usable level.

Kristof,

The graphs in CAS, when I ask for example a 30 day overview, is show only 10 days and the yellow diamant says no more data available before that time.

So it looks like I have no history in CAS

KR Henk Stobbe

 

 

Henk,

This is due to the CAS only keeping 5minute intervals for 10 days.  This is configurable via atscon, but will have capacity implications.

If you change the period to daily, the data should exist for further back in time.

Cheers,
Morgan 

Morgan,


 


I asked CAS for 30 day historical data, that makes it strange,


KR Henk


 

Hi Henk, from your screenshot I can see that the Resolution is still set to "1 period".

1 Period refers to the highest resolution of data captured (which is by default 5 minutes).

Can you change the value in the Resolution drop down to something higher? 

This should display the data.

henk_stobbe
DynaMight Pro
DynaMight Pro

Kristof,

This does not work, for some reports the resolution 1 period, 1 hour or 6 hours can only be selected. And CAS reports data is missing, The RUM overview Applications and Tiers will do this,

In Rum overview Sites, I can choose extra resolurions like day and week, in this one you solution works,

 

KR Henk Stobbe


 

Henk, 

the reason why you don't see data on that report (and probably on many others) for the historical time ranges (like Last 30 Days) is that a report in DMI can be build not only on the main (subject) data view but also on the auxiliary (benchmark) data view. If **any** of the sections in the report uses a baseline data view, e.g., "Software service, operation, and site baseline", you will not see any data for other than 1 hour (6 hours) or 1 period. On the other hand for the historical data, the main data view supports only resolutions lower than 1 day due to aging process which aggregates data older than 10 days (default) into 1 day buckets. 

When you switch over to Last 30 days - the benchmark data view resolutions take priority and you see only those in the resolution selector. I will talk to the team to see how we can improve the user experience here.

In the mean time - can you please import the report I have attached: Network Landing Page - Last 30 Days.xml.

It is the same Network Landing Page but tailored for Last 30 Days view by removing benchmark data views from all (actually just 1) sections in this report. I hope that with this report you will actually see your data beyond last 10 days.

Best,

Sebastian

Sebastiaan,


It did not work the first time, within the xml v6 had to be changed in v4, and your XML has enabeled not only graphs but also data. But your presumptions are right, all data is visable!


FYI this all changed after a reboot of the system,vso which benchmark data view is resposible and why.... 


 

Henk,

my fault. I forgot you were not on 12.2 yet. 

Regarding which baseline you need to remove: in the Section 5 (see below) there is a benchmark set to "Software services ... baseline". When you remove it, you will be able to select 1 day for resolution in last 30 days time range.

However, I don't think that before the reboot there were charts filled with data for all 30 days.  Do you have any reports in PDF or MHT, or screenshots from before the reboot to help me investigate that?

Best,

Sebastian

Sebastiaan,


When I looked at the CAS (we had issues with graphs in the EP) I noticed that the grahps in the CAS did not go back futher then 10 day's. Looking at the system logs I found that the system was rebooted 10 days ago. Hence my haste conclusion! 


You are absolutly right nothing changed, I just noticed it for the first time,


 


Thanks for you assistence


 


KR Henk Stobbe

Henk,

glad I could help. 

Best,

Sebastian