Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

Application health index understanding


i have an application where the front-end server is always been very low percentage of health index.

I am not sure what causes this. Operation time are still within threshold.

Can someone please advise.

Thank you.




Hello Elvin,

Health index is the percentage of front-end operations completed in a time shorter than the defined performance threshold compared to all operation requests.

As per my experience if there are number of failed operations in the request breadue to any reason will also impact the health index even though the operation time is fast or within the threshold.



Hi Babar,
Thank you for your time explaining.
For this particular tier of mine, it has very less to no failures, so i can assure its the number slow operations that causes the health index to be low. However, I changed the operation time threshold from 8 secs to the maximum value yet I still see red bar (slow operation in my AHS). Any idea why ?

Are you sure we are talking about operations in your screenshots above and not sequence transactions or anything else? Where are you editing the operation time threshold? At the AMD configuration, in the software service? Maybe there is another valid threshold.

You can create a tabular report and add the metric "Max. operation time threshold" to get the valid threshold for your service.

Dynatrace Consultant and Center of Excellence Expert

i edit the operation time threshold in software service

Hello Elvin,

Did you make a DMI report for the software service and used the metric 'Max slow operation threshold' to know the exact number?

Did you modify the 'Slow operation load time threshold' in the software service?

What maximum value did you set in the 'Slow operation load time threshold'?



hello, appreciate both your feedback and sorry for my late reply as i was out of office for the weekend.

i have make a DMI for "Max slow operation threshold" and it shows 500ms but i set it to 12seconds in the software service.

By the way, the software service is running on SSL analyzer. I have also found out that the max operation threshold for all SSL analyzer based software service are capped at 500ms. Is this how it suppose to be?


Hello Elvin,

There are two types of settings to define the slow operation page threshold. One which is configure globally and applied on all the software services and the second one which you can configure on the software service to override the global settings

Below screenshot is from the global settings of an AMD where slow operation time threshold is configured 8.000 seconds.

And the below screenshot is from the HTTPS/SSL software service where you can un-check the inherit from global setting and provide a desired threshold for the specific software service.

Just go through both of your settings and share your findings with us.



hi Babar,

i have tried playing both of the settings (AMD global setting and software service setting) but still shows the same result.

i have found out that generic tcp analyzer threshold are capped too.


Hello Elvin,

I did not get your point about the 'generic TCP analyzer threshold are capped too'.

Can you please explain a bit here?



Over here, you can see the screenshot i attached which are all SSL and Generic analyzer. Both of these analyzer "max slow operation threshold"
shows 500ms. Changing the threshold to a custom value doesnt work. It still shows 500ms. Anyway, i have opened a support case for this problem. Not sure if it is a bug or this is how dcrum works

thank you for your time responding to my question.

Appreciate alot

Hello Elvin,

Great that you already opened a support case to get their assistance.

May I know which DCRUM version do you have?



version 2017

Hello Elvin,

I had an almost similar situation with the database global settings in the version 12.4.14 so I though may be you have the same release.

I was suggested to restart the AMD server(s) to address the issue which I will have to do this activity sooner.

If possible for you then restart the AMD server(s) and check the impact in case the same is on your end.