Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

Cannot create SQL database for network analyzer



May I get your help?

I met issue when installing network analyzer 12.3. I have installed this software successfully (with skipping the database connecting step when installing)

Then, I downloaded the latest SQL express 2012 per your suggestion (installation file name is SQLEXPRADV_x64_ENU) from Microsoft official website. And I have installed it.

The two installation above both run smoothly but when I tried to use the APM Database Utility to create the database for network analyzer, the issue came out.

I have made sure that the SQL server database is running in Mixed Authentication Mode on my PC however, but it always shown the error like:

SQL server does not exist or access denied.

Please verify that there is a SQL server instance running in Mixed Authentication Mode on your server.

Microsoft SQL Server 2005 Express is include in Vantage DVD 3.


I tried to uninstall and re-install both of the two software many times but still failed. Could you please help me to resolve this issue? This should be the final step for me to use Network Analyzer. Please assist.

If you have any questions or comments, please let me know.

Thanks in advance.

Looking forward your reply.


Dynatrace Guru
Dynatrace Guru

FYI - I am moving this to the DCRUM Forum as it is currently posted in Dynatrace AppMon. Based on your question I think this is meant for Data Center RUM



It seems you're trying to reach SQL Server instance with "local". This looks like a typo - did you mean "(local)"? You can also try to connect to a local SQL Express instance at "" or "localhost".

As a troubleshooting tip, you can always use SQL Server Management Studio Express (free) to verify you can log in to the server using the exact same server name and administrative password.

Hope that solves the problem.


Hello Tomasz,

Thanks for your reply. I meant localhost in my previous question.

After getting your answer, I tried to log in with "localhost" and I got the same error there.

I can log in SQL Server Management Studio with localhost server by using windows authentication or sa account.

My problom is still there. Could you please give me more comments?

Thanks you

Hard to diagnose without more details, but let's try some more guesswork. Dynatrace Database Utility allows you to connect to SQL server using either sa account or Windows authentication, similar to SQL Express Management Studio, so it's pretty unusual one of them works while the other one doesn't.

1) Are you connecting to the default or named SQL Server instance?

2) If possible, please post a screenshot showing SQL Server Management Studio login screen and Dynatrace DB utility server connection step.

3) Have you tried as server name? Localhost should resolve to it, but it could be specific to the machine configuration.

4) Do you have any firewall/antivirus applications running in the background? Please verify they're not blocking connection to SQL Server from DB utility.

Sorry to hear you're having issues setting up a database. Is the screenshot attached to the question accurate? Does it still say "SQL server does not exist or access denied." or something else?


Thank you so much for your quick reply.

1) I logged in the default SQL server instance which is localhost.

2) I got some other screen shots for you. Hope they will help.

3) I tried what you mentioned and could login my SQL by using SQL instance name - localhost but could not use to login SQL, it seems like my PC does not support this way to log in.

4) I don't install any anti-virus software in my PC and I tried to shut down the only window firewall there. But the issue is still there. 😞

5) Yes, the alert in my previous screen shot is accurate.

If you need more detailed info. from me, please let me know. Thank you~



Opps, I forgot to attach the pics.

Thanks for the screenshots. That's a surprise here - why won't SQL Server accept connections at

Maybe you have TCP/IP protocol disabled in SQL Server configuration,
could you please verify with SQL Server Configuration Manager?

2) What does "ping localhost" return? Maybe you have IPv4 disabled on your PC.

3) Meanwhile, here are some useful ideas for diagnostics from Microsoft:

I'll try to get the issue reproduced in-house. Let me know if you make any progress.




4) Actually, if by chance you have installed a named instance instead of a default SQL Server instance, you would be connecting to it at "(local)\SQLEXPRESS" - could you give it a try as well?

Hi Tomasz,

Thank you for your reply. Per your comments, I have enabled TCP/IP protocol and I could connect server instance by using '' to log in.

Then, I went to APM database utility to create database again.

I was failed again, but the error message changed.

Please take a look at the screen shot.

Could you please give me your comments on this new error?

Thanks a lot.



Now that looks like an incomplete installation. It looks as if you installed SQL Express *after* DNA console installation - is that correct? Please rerun OS Update installation (or remove and install again). The missing part is most likely SQL Server 2005 Backward Compatibility, which is installed with Dynatrace OS Update.

Hope this helps.


Hi Tomasz,

I have rerun SQL Server 2005 Backward Compatibility, and it helped me to create database. Now, I'm logging in network analyzer.

Your comments are very helpful. Thank you so much.



Glad it worked. Have fun with DNA console.