cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Cannot find kickstart file on CDROM VMWare

yohanes_santoso
Contributor

I stuck in getting error "cannot find kickstart file on CDROM".

I tried to install AMD on my virtual server using ESXi VmWare. I have checked that boot from cdrom went fine by using it to boot RHEL as AMD OS. And I have checked too that my DCRUM disc contains AMD/amdrhel6.cfg. I got DCRUM CD by download the iso file on community.

I put "cdrom:/AMD/amdrhel6.cfg" on kickstart parameter.

Anyone got an idea why it happened? I stuck in here since yesterday.

8 REPLIES 8

adam_piotrowicz
Dynatrace Pro
Dynatrace Pro

So you put:

linux ks=cdrom:/AMD/amdrhel6.cfg

in the boot prompt as per docs?

If you mount the CD in any other Linux, is the file readable, like:

cat /AMD/amdrhel6.cfg

?

The CD worked in any other Linux, I have tried that.

Any other idea?

Can you switch to the console when experiencing this problem and see if you don't have similar errors:

If so it would mean the ISO had bad format.

Pelase let us know.

P.S. What version this is?

adam_piotrowicz
Dynatrace Pro
Dynatrace Pro


OK, if you can try do it as I do on my ESX:



  1. When virtual machine starts mount RHEL ISO,

  2. When you go to boot prompt write:


linux ks=cdrom:/amdrhel6.cfg

and hit Enter,

  • When it will complain that there is no kickstart on RHEL ISO, mount this one and hit Enter again,
  • When it will ask for RHEL ISO mount it again.
  • I know that should be no bigger difference in which ISO the kickstart is incporporated but this used to work for me.

    The ISO with kickstart is just this very one file ...

    Thanks a lot Adam, that worked.

    Any reason for that?

    The original ISO is in UDF format that RHEL installer is unable to mount and find kickstart file.

    The workaround was to extract the file from ISO on another system and make one-file ISO in ISO9660+Juliet format.

    Alternatively USB stick could be used also.

    We're working on permanent solution.

    Thank you Adam for your help.

    adam_piotrowicz
    Dynatrace Pro
    Dynatrace Pro

    DC RUM 12.3.5 ISO has been re-formatted and divided into Windows and Linux.

    Now after inserting Agentless Monitoring Device with Kickstart Files when installer asks for kickstart file fixes the probelm.