cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

DC RUM - Synthetic integration PLM not showing

matthew_eisengr
Inactive

Hi All,

I've got a 12.4.6 environment with all patches applied and have just added the DPN account to incorporate synthetic data. Within the first 10min the backbone data started pouring in; however the private last mile data isn't. Any ideas? I can confirm that the PLM has data points in the synthetic platform.

7 REPLIES 7

From the top of my head - couple of places I would look into:

  • CAS log - does it say anything like
E GPN	16-09-09 07:50:41.935	adlex.rtm.jobs.gomezsaas.GpnClient cannot get data from Gomez DataFeed Web Service. Returned status:STATUS_FAILED message=Max number of concurrent sessions exceeded
  • you could enable GPN_SAVE_RAW_DATA system property (Administration console - General properties editor) to have XML payload of the SOAP communication with Portal stored in the CAS folders - and check whether you see PLM test results there
  • if there are delays in getting data to CAS, it may not wait for specific data source. By default it's 30 sec now. You can change it in rtm-cv.properties file in the following entry
gomezdata.MAX_SAMPLE_WAIT_TIME=30

mitchell_pearso
Newcomer

Hi @Matt E., @Sebastian K.

I can see in the logs that the CAS was able to get all data;

T GPN16-09-09 10:25:25.006[DPN] Start getting data for file=D:\Program Files\Dynatrace\CAS\gpn_samples\dcrumaccountgomezdata_57d28dfc_5_t from probe=5

T GPN16-09-09 10:25:35.805[DPN] Got 9 PRIVATE_PEER records

Then looking in the sample file I can see the private last mile data;

GS 1473413199540 ***%20Group%20(***.com,%20***%20***) 799022 Prod%20-%20***%20-%20Chrome%20Agent 3 8 Logout 0 - - DataCentre/Stores%20Group UNITED%20KINGDOM BT ***.**.***.*** - - - - - 410701 453 9 7 5 2 0 0 0 2 6 0 0 0 0 0 4 2 5 2 447 14 141 14 2721 0 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1

It is just not showing data in the Synthetic Private Last Mile overview.

Hmm that's really weird. I think we have to hand it over to the support team.

mitchell_pearso
Newcomer

Hi @Sebastian K., thanks for the suggestion, I will raise a ticket.

Hi Matt

Not sure if it changed or not in 12.4 but in 12.3 you have to specifically enable PLM data.


  1. Log on to the CAS as an administrator.
  2. Open the report server Diagnostic Console by typing diagconsole in the browser's Address field:http://server_IP_address/diagconsole
  3. Select Advanced Properties Editor in the Configuration Management section and click to add the new property. Add GPN_GET_LAST_MILE_DATA to the Name field and set Value to 1.
  4. Click to accept changes.

Couldn't hurt to try.

Regards

Alasdair

I should not be necessary in 12.4.

mitchell_pearso
Newcomer

Hi @Alasdair P., I added that property and it doesn't appear to have allowed the PLM data to be seen.

Thanks for the suggestion.