cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Excluding operations from Tier

Carl_Morphet
Dynatrace Mentor
Dynatrace Mentor

Good Afternoon Everyone, 

I'm trying to exclude a number of operations (known to 404) from a Tier in DC RUM 12.2.2, 

I've defined them as Tier rules using the ~(operation) syntax (highlighted in green) additionally with a wildcard operation rule (highlighted in red) to allow other operations to be logged in the Tier, please see the attached screenshot for clarification.  DC RUM Exclude Operation Rules.png 

Unfortunately I believe the wildcard rule takes priority, the excluded operations still appear. Is there any way to change this or a better way to exclude operations from an application?

(Other than filtering them out at a Software Service level) 

Thanks for the support, 

Carl

10 REPLIES 10

Have you type=Expression, with Label as something like task="AnotherPageName",operation=~"http://server/test/*aspx",operation="~http://server/test/excluded.aspx",operation=* ?

Carl_Morphet
Dynatrace Mentor
Dynatrace Mentor

Hello Sebastian, that appears to work, thank you! 

EDIT: I think I spoke to soon, I've tried a number of combinations of 'operation="(URL)",operation="*"' but unfortunately see no operations after setting the rule

Do you know if expressions are evaluated in a particular order?

I'll be filtering out 300-600 operations so any improvement would count

Let me checked with the dev team.

adam_piotrowicz
Dynatrace Pro
Dynatrace Pro

From what I remember between conditions within expression we assume AND operator and between the rules it's OR.

Maybe it's and answer to your entire question ...

Carl_Morphet
Dynatrace Mentor
Dynatrace Mentor

Good Afternoon Adam, unfortunately 'operation="*",operation="~(operation_string)"' as a single expression rule does return any results 

If I'm understanding it correctly shouldn't this expression return everything that is not operation_string?

I see it as: anything AND NOT (operation_string) 

Carl, please use 'operation="**"' instead of 'operation="*"'. I am trying to figure out why is this the case - but this is the only way it works for me.

Carl_Morphet
Dynatrace Mentor
Dynatrace Mentor

Hello again Sebastian, unfortunately I still receive an expression is invalid error when using the below syntax:

operation="**",operation=~("request_to_be_excluded"),operation=~("request_to_be_excluded_2"),operation=~("request_to_be_excluded_XX")

Could I possibly see what you are entering?

Hi Carl,

here is the example that works: operation="**",operation="~*orange*"




Hi Sebastian,

could be a good idea updating the documentation with examples and usage of the rule definition Expression type?

Thanks a lot,

Raffaele

Carl_Morphet
Dynatrace Mentor
Dynatrace Mentor

Outstanding, thank you for the help Sebastian!

The issue appears to be in the operation to exclude syntax, I did not realize a wild card before and after the operation was required despite the one to one match on the operation string as such:

operation="**",operation="~*exclude_operation_string*"