cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

Font type on Legends in generated reports

tarjei_utnes
Organizer

Hi,

I see that the Legends for the charts that gets generated when you make a pdf are fonts withs serifs. These fonts are rendering poorly.

Before we patched to version SP3 (12.1) they were Sans-Serifs but now with separate legend set to True, they are with serifs.

Are there any settings / fixes to alter this?

10 REPLIES 10

Adam_Tryba
Dynatrace Advisor
Dynatrace Advisor

Hi

 

PDF fonts are controlled by property named 'PDF_TTF_FONTS'

Which is available when you log in to http://adress_of_your_cas/userpropertiesadmin

By default there is following value in there:

ARIALUNI.TTF;GULIM.TTC,0;ARIAL.TTF

What are the values on your environment?

 

Best Regards

Adam Tryba

tarjei_utnes
Organizer

These are the values:

ARIALUNI.TTF;GULIM.TTC,0;ARIAL.TTF

And this is how the exported chart looks: See the Legend

 

adam_litwin
Dynatrace Participant
Dynatrace Participant

Please check if you have ARIALUNI.TTF (Arial Unicode MS Regular) file in C:\Windows\Fonts\

It should be visible on the server and the client machine. Did you try to create pdf report from different client machine?

I do not have the ARIALUNI.TTF installed.

What is the suggested font to change to?

tarjei_utnes
Organizer

I have now installed the ARIALUNI.TTF on the CAS.

I does not seem to work still.

adam_litwin
Dynatrace Participant
Dynatrace Participant

After adding the font you have to restart the machine

tarjei_utnes
Organizer

Restart the machine or the service?

adam_litwin
Dynatrace Participant
Dynatrace Participant

The restart of machine guarantee that new fonts become accessible

tarjei_utnes
Organizer

There is no problem with the font when i don't select 

DMI_REPORT_CHART_HC_EXPORT_SEPARATE_LEGEND to be True

But then, I don't see the whole software service names on the legend

adam_litwin
Dynatrace Participant
Dynatrace Participant

In 'chart settings' you can set 'legend position'='always below' - you can try that. If it doesn't solve the problem please open support ticket