cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

How can one freeze a 12.4.7 CAS Cluster in time?

anthony_percy2
Inactive

Any details on how to stop the aggregation process on a CAS cluster that no longer has any new AMD data?. We want to preserve the CAS database at a set point in time so it can be a baseline for a newer CAS system...

Best Regards

Anthony

15 REPLIES 15

Which aggregation process do you have in mind?

anthony_percy2
Inactive

We just want to stop the "clock" on the CAS so that it stops its aggregating tasks. Therefore when you login it would just show data up to the time it was "stopped" . This is what is done on say a DCRUM demo system for example. It involves stopping certain scheduled tasks on the CAS but I not seen any info for when this is a CAS cluster...

If you want to stop processing on CAS then the simplest way to achieve this is to disable data feed from all probes (AMDs). It will be propagated to all nodes within a cluster automatically.

The "clock" on CAS "ticks" when samples are being processed. If there are no new samples time does not pass by.

If AMD still generates samples but empty ones it's a different story. You have to execute DATA PROCESSING CONTROL diagnostic command and press on "Stop processing" button.


anthony_percy2
Inactive

True, but I think that wont stop the clock ticking on the CAS as it were e.g if I had stopped the data feed say two days ago, then I would have two days on the CAS with no data... Eventually after 10 days of no data, all my 5 minute data would be gone and replaced with 10 days of no data?

As Tomasz stated the clock ticks only when samples are processed. So if no samples are processed the CAS clock stops. Daily maintenance tasks are also scheduled with sample-based time so they will not be triggered.

anthony_percy2
Inactive

Thanks for your answers but it appears that's not what I am seeing on the CAS in question . I did disable the AMD data feed to CAS 3 hours ago, and now the CAS says there is a delay of 3 hours in the processing time with the red octagon icon. I totally agree in that it is now only showing data up to say 3 hours ago but the clock appears to be ticking still on the CAS...

Maybe not all data sources were disabled. Check on <CAS>/rtmdebug servlet what is the current CAS time.

Most scheduled tasks are based of 'SAMPLES' time (so only will run as new data is processed).

There
are a couple that run on 'SERVER' time (so will run based on the
clock), two of these will expire/aggregate old data, and need to be
stopped - or re-configed to run on SAMPLES time, which won't change
without new data coming in.

- WeeklyDBMaintenance

- TableDailyTask

ulf_thornander3
Inactive

I would also stop all the maintenance jobs - just to be on the safe side.

Christopher_Cha
Dynatrace Advisor
Dynatrace Advisor

One unorthodox way of freezing the time of that particular CAS is removing the license from it... This way you'll always see the CAS showing the time on the day the license expired/stopped working.

anthony_percy2
Inactive

Thanks everyone for all your answers here... The CAS is now frozen although it still says there is a <x> delay in processing where x = the number of days since it was frozen....

Best Regards

Anthony

ulf_thornander3
Inactive

Thanks for the feedback - which one of all the tips was it that worked?

Or did you do them all 😛

john_leight
Dynatrace Pro
Dynatrace Pro

I suppose another way is to go to the admin console -> processing status -> I think there is a pause/stop processing button there.

That'd work, but is temporary, in that if the CAS service was restarted, it would continue processing.