cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

How to enable non-processing CAS server

adam1
Newcomer

Hi,

I have heard we can have non-processing CAS server that will read the data from other CASes.

How to enable it?

6 REPLIES 6

Hi Abdul,

There are two possible configurations. A reporting server (non-processing) can be either a primary node in a primary cluster or a stand-alone instance with reporting data server(s) attached.

A Stand-alone instance


The server must not be part of the cluster, i.e it has to be the standalone instance with no data sources (AMDs) attached to it.

1. Add this CAS in RUM Console to the device list. Do not add this CAS to any cluster.
2. Access

/DiagConsole#/userprops

add a new property:
name NON_PROCESSING_MODE
value true
3. Restart CAS server
4. Open RUM Console > Devices > Reporting CAS > Open Configuration > Reporting data servers
and add primary (node) CAS as a report data server to this Reporting CAS
5. Redirect all end-user and external applications calling DMI's Web service to this new reporting CAS,

 

A part of the farm

The server must be a primary node in the main cluster with no data sources (AMDs) attached to it.

1. Add this CAS in RUM Console to the device list. Do not add this CAS to any cluster.
2. Access

/DiagConsole#/userprops

add a new property:
name NON_PROCESSING_MODE
value true
3. Restart CAS server
4. Create a farm with at least 2 clusters. In the main cluster, the reporting server should be the only node. The rest of the farm can be defined freely (one or more clusters with the desired number of nodes).

 

Although this is a great idea, I would be hesitant to implement this. We have run into an issue where IF the primary node CAS in the cluster has no data sources (AMDs) attached to it like you are suggesting, THEN the reports generated (via all aggregate mode) on that CAS do not display correctly because the primary node CAS has no data source/AMD to provide it a data time reference. Directly related SUPDCRUM-23508. We had to add an AMD to the primary node and give it a bogus IP Filter list so it doesn't process any data, but has a time reference. Does the NON_PROCESSING_MODE property handle this bug? Thanks!

That's exactly what's that feature for. When the property is turned on, the primary CAS will collect sample times from the remote nodes and tune itself to it. So the time will flow on the non-processing server despite not having any AMDs attached.


travis_booth
Helper

IMPORTANT UPDATE:

This setting needs to be applied in GENERAL PROPERTIES NOT ADVANCED PROPERTIES

/DiagConsole#/userprops


paul_eggert
Inactive

What problem does this question, enabeling a non-processing CAS-server, trying
to solve? There is a reason to introduce a non-processing CAS.

Regards

Paul


Reporting load, if you have enough users and/or complex enough reports, can become a significant enough drain on resources to cause data processing to fall behind. Adding a report only node moves this off the data processing nodes.

-- Erik