cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

I/O Error When Trying to Initiate Trace from RUM Console

anton_laurila
Advisor

Hi All,

Recently after upgrading from 12.4.2 to 12.4.5 tried performing a trace from RUM Console for the first time since the upgrade. Getting an error with the capture being stopped immediately, please see the attached screenshot.

Kind regards

Anton

4 REPLIES 4

mark_gerards
Dynatrace Pro
Dynatrace Pro

Dear Anton,

The most likely cause is that the folder where the AMD tries to store the capture file does not exist. I know that since 12.4.5 this folder changed.

  • < 12.4.2 folder is /var/spool/adlex/cba
  • > 12.4.5 folder is /var/spool/adlex/spc

There create the folder spc and give it the same rights (chmod) as the other folders and change owner to compuware (chown).

Kind regards,

Mark

Hi Mark,

This indeed was the issue, missing folder spc. Following the steps fixed the issue, also confirmed by support.

karol_malecki
Inactive

Hi Anton,

We tried reproducing this issue so it doesn't happen anymore but it didn't occur in our setup.

Could you provide upgrade.bin.log from location /var/log/adlex ?

Then we could try reproducing this again, this time with exact builds and system.

Regards,

Karol

mark_gerards
Dynatrace Pro
Dynatrace Pro

Dear Karol,

Anton is on holiday, therefore I uploaded the requested upgrade.bin.log to the ticket Anton created in the past for this issue. The ticket is SUPDCRUM-12999

Kind regards,

Mark