cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

NAM Probe stops responding after RedHat OS update

przemyslaw_tafe
Dynatrace Pro
Dynatrace Pro

Problem

NAM Probe stops responding to NAM server following the recent RedHat OS update.

No data is sent to NAM server and NAM Probe shows connectivity problem in NAM Console.


Symptoms

The following error is presented in rtmgate.log file:

It is not allowed to configure supportsCredentials=[true] when allowedOrigins=[*]


Root cause analysis

Problem was introduced by a new version of tomcat package:

  • last known working tomcat version was 7.0.76-9.el7_6.noarch
  • new version of tomcat that breaks rtmgate is 7.0.76-10.el7_7.noarch


Solution

Download and install NAM 2019 service pack 2.

  • The same fix will be included in NAM 2018 service pack 6 that is coming soon.
  • If you use NAM 2018 or an older version use the workaround below.


Workaround

  • Edit /var/lib/tomcats/rtmgate/webapps/ROOT/WEB-INF/web.xml.
  • Find the following section:
    <filter-class>org.apache.catalina.filters.CorsFilter</filter-class>
    <init-param>
    <param-name>cors.allowed.origins</param-name>
        <param-value>*</param-value>
    </init-param>

and change it to:

<filter-class>org.apache.catalina.filters.CorsFilter</filter-class>
<init-param>
<param-name>cors.allowed.origins</param-name>
    <param-value></param-value>
</init-param>
  • Restart rtmgate service: service rtmgate restart

0 REPLIES 0