Showing results for 
Show  only  | Search instead for 
Did you mean: 

No emails for alerts when using Data Access Control


We are using Data Access Control where we
use user groups to define the specific dashboards users can see, as well as using
user groups to control what role those users receive. We cannot have our users
seeing other application’s data. When we deployed this security, emails would
not work for the users who need to be notified of an alarm email alert. The
only way we can get alerts to go out is to set everyone’s access rights to
admin. We’ve tried multiple combinations of roles and user groups
but the emails will not be sent to the users no matter what combination we’ve
tried except for admin role. Does anyone know why this is not working. Please
see the attached file. There is a warning message next to the user that may
explain what the issue is but tool tips will not display for this warning. DCRUM version 12.4.6 -


According to the documentation:

user can only view existing reports or create new ones that are based on the DMI views that include the selected filtering dimension.

Hi Barbara,

We have it filtered out by application, and when we set the data access control on the user group to have access to the application and the responding reports... users do not receive email alerts.

We have email alerts set up on these applications so that when our ESM robot reports that a transaction in the application had failed 2 times in a row, an email alert is generated.

Matt's attached picture shows that some warning symbol is present, though no tool tip is there to explain what that warning symbol is in reference to.

We are able to force the symbol away by giving the user's group the System Administrator role. When we do this, email alerts resume as expected.



Dynatrace Helper
Dynatrace Helper

I was able to inspect the element and noticed that the span title references "1 distinct notification(s) on 1 device(s)." almost as if this is what the tooltip was supposed to say.


The missing tooltip issue was fixed in build. The missing tooltip would explain why the notifications won't be send to the user. Please open a support ticket for this issue.