Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

OSA Error in DNA 12.4



Received following error when trying to add a remote agent in DNA 12.4. Agent is old AV (unknown version).

"OSA Error - Connection request is refused."

Was working. But because I was unable to remove duplicate packets with Power Tools,

I decided to install DNA agent. This failed. So I backed out the DNA agent install, reinstalled the CW driver. And now this error message.

Please help as I have a capture I must do at 9:30 AM EDT. Unfortunately, I will not read any responses until 8:00 AM EDT.

Thanks in advance for any help.

God bless,


PS. If an application produces an error message, there should be documentation available that states how to troubleshoot it. Someone wrote the error message, right?

(another error


Dynatrace Helper
Dynatrace Helper


Looks like the application (console) didn't found some information. Did you try to run the power tools outside of DNA?

So, the console installation seems corrupted. Try to run the repair installation.




Sorry about
your experience with the agent installation and the Duplicate Packet Remover. Such
issues can happen when the installation process is run in a restricted
environment, under a limited user account, or with an oversensitive antivirus/security
suite running in the background.

Speaking of
the agent, it’s a fairly lightweight package and rarely causes trouble
installing. It does install a service and a packet capture driver, though, so administrative
privileges are required.

1) Can you
double-check you’ve tried to install the agent under an administrative account?

2) Can you
verify your firewall isn’t blocking connections on port 2408 (or your selected
port, if you changed the default)? There should be a firewall exception named
similar to “Transaction Trace Agent” or so in Windows firewall. If you can’t
find it, or if you’re using another security tool, then you should add it

3) Are your
agent and you console machines in the same network profile (private vs public)?
I know this can prevent console connections to the agent if they're in different realms.

4) Can you
connect to the agent using the old Agent Manager tool installed with the agent?
You can find it in the Start Menu. Does the agent let you in when you connect

5) There are
even lighter options to capture traffic other than DNA agent, if setting up a
service is problematic, or when inbound connections to the agent are somehow
restricted. If you can connect to the machine using Remote Desktop, you may
consider using SimpleCapture utility. You can find it in the DNA installation
directory or on a DNA installation medium, or download from here:

(Be sure to extract it
to an easily writable location so that it could save its own log next to .exe,
and run it as administrative user as well.) Read more at:

Hope this




@Tomasz S.

Thanks for the utility. I can see this being a great tool for when I want users to capture from their PC, and I don't want to filter out any traffic. For an agent running on a PC capturing port SPANs, I will use the normal agent procedure.

I deleted NV from the PC and installed the DNA agent from scratch. All is good.

@Allison A.

Where do I find the executible for PowerTools outside of DNA?

Thanks and God bless,


Glad to hear the agent installation worked. It's true that an old NV probe could interact somehow with the DNA agent, they share drivers (DNA has an updated one), so they shouldn't coexist definitely.

SimpleCapture lets you filter traffic just as well as the full agent, through a config file (BPF filters only). But the full agent setup is obviously more convenient for remote operation, so you can use whichever works best for you.

@Tomasz S.

Thanks for letting me know about the configuration file. This utility could be useful for our helpdesk when we want them to capture traces and we don't have the time or resources to setup agents in DNA.

Thanks and God bless,


You're welcome, thanks for using the Community! 🙂